Bug 788805 - unbound fails to start when first installed
Summary: unbound fails to start when first installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: unbound
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 797998 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-09 02:53 UTC by Jason Tibbitts
Modified: 2012-03-08 05:04 UTC (History)
3 users (show)

Fixed In Version: unbound-1.4.16-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-06 20:44:48 UTC
Type: ---


Attachments (Terms of Use)

Description Jason Tibbitts 2012-02-09 02:53:24 UTC
I installed unbound-1.4.14-1.fc16.x86_64 and attempted to start it.  Startup hung for a long time and eventually failed, with this in the log:

Feb  8 20:05:43 hippogriff unbound: [12542:0] error: cannot open pidfile /var/run/unbound/unbound.pid: No such file or directory
Feb  8 20:05:43 hippogriff unbound: [12542:0] error: cannot chown 112.111 /var/run/unbound/unbound.pid: No such file or directory

The problem is that /run/unbound did not exist immediately after the package was installed.  A call to systemd-tmpfiles --create was required to get it to exist, though I guess a reboot would have done it as well.  This is because the directory is listed in the rpm but marked %ghost.  Ghosting the directory causes the package to own it, but not to actually create it at install time.

The guidelines: https://fedoraproject.org/wiki/Packaging:Tmpfiles.d#Example_spec_file

indicate that the directory should not be %ghost'ed.  It does say you can %ghost files that get created underneath that directory at runtime if you like, but it's not necessary.

Comment 1 Paul Wouters 2012-02-28 02:02:50 UTC
*** Bug 797998 has been marked as a duplicate of this bug. ***

Comment 2 Paul Wouters 2012-02-28 02:12:49 UTC
fix commited to unbound-1.4.16-2

Thanks!

Comment 3 Fedora Update System 2012-02-28 02:22:42 UTC
unbound-1.4.16-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/unbound-1.4.16-2.fc16

Comment 4 Fedora Update System 2012-02-28 02:23:21 UTC
unbound-1.4.16-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/unbound-1.4.16-2.fc17

Comment 5 Fedora Update System 2012-02-28 09:58:36 UTC
Package unbound-1.4.16-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing unbound-1.4.16-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2567/unbound-1.4.16-2.fc16
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2012-03-06 20:44:48 UTC
unbound-1.4.16-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2012-03-08 05:04:16 UTC
unbound-1.4.16-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.