Bug 788870 - BIND logs errors about DNS environment too verbosely
Summary: BIND logs errors about DNS environment too verbosely
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-09 07:28 UTC by PGE
Modified: 2012-07-27 14:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 13:41:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0830 normal SHIPPED_LIVE bind bug fix and enhancement update 2012-06-19 20:49:20 UTC

Description PGE 2012-02-09 07:28:29 UTC
Description of problem:
Trying to filter AAAA records like this:

options {
 filter-aaaa-on-v4 yes;
 filter-aaaa { 192.168.0.1; };
};


Version-Release number of selected component (if applicable):
bind-9.7.3-8.P3.el6_2.2.x86_64


How reproducible:
All the time


Steps to Reproduce:
1. Install bind.
2. Try to enable filter-aaaa & filter-aaaa-on-v4.
  

Actual results:

/etc/named.conf:64: option 'filter-aaaa-on-v4' is not configured
/etc/named.conf:64: parsing failed


Expected results:

No error messages like this in logfile:

named[1269]: DNS format error from DNSSERVER#53 resolving www.dom.tld/AAAA for client IPADDRESS#54915: invalid response

Additional info:

Comment 2 Adam Tkac 2012-02-09 10:50:48 UTC
The filter-aaaa* options don't help you with the "invalid response" errors. Those errors indicate that other servers respond with invalid answers.

The filter-aaaa* options aren't currently compiled in bind and their primary use is not to return AAAA records to clients. They don't control if named asks for AAAA records and caches them (named always asks for AAAA records).

More proper solution for this issue is to backport patch for bug #645544 to RHEL-6. With that fix those error messages will only appear when you start named with "-d1" parameter.

Comment 9 errata-xmlrpc 2012-06-20 13:41:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0830.html


Note You need to log in before you can comment on or make changes to this bug.