Bug 78894 - Bad dhcpd.conf file - but no error msg and dhcpd starts anyway
Summary: Bad dhcpd.conf file - but no error msg and dhcpd starts anyway
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-03 00:02 UTC by RLX Technologies
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 16:37:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description RLX Technologies 2002-12-03 00:02:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
On previous versions of DHCP (2.0pl5), we would see the error msg 
"No subnet declaration for eth?" if the dhcpd.conf was wrong (i.e. missing
subnet data for the given interface).  With the DHCP on 8.0 
(3.0pl1) we see no error and dhcpd starts when it should not ?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Comment out the subnet statement for one of the interfaces
2. service dhcpd restart
3. No error msg and ps -ef shows dhcpd running on the bogus interface
	

Actual Results:  dhcpd runs and gives no error msg as that seen when using 2.0pl5.

Expected Results:  dhcpd should refuse to run and give error msg 
"No subnet declaration for eth?".

Additional info:

I am not a frequent user of dhcpd but this issue came up in the testing group
and was a "surprise" to the person doing the testing of 8.0.

Comment 1 Daniel Walsh 2002-12-05 14:26:56 UTC
Did it report errors in the syslog.  I am new to this code and quickly reading
through the code shows that it should report the missing subnet in the syslog file.

Dan

Comment 2 RLX Technologies 2002-12-10 23:48:56 UTC
Yes, it does report an error in the syslog.  I see "No subnet declaration for
eth0" and other very good error msgs.  We just expected this case to cause a
failure and stop dhcpd from starting.  If this is "Working As Designed", then I
will inform the testing group.  What do you think ?  By the way, sorry for the
delay in the reply - I was busy on a few other issues.  Thanks ...

Comment 3 Daniel Walsh 2002-12-16 16:37:45 UTC
Looks like it is by design, since there is a comment before the syslog message
saying ignore it.

Thanks
Dan



Comment 4 RLX Technologies 2002-12-16 17:29:26 UTC
Thanks for the info/help ...


Note You need to log in before you can comment on or make changes to this bug.