Bug 788997 - Group description not limited by UI
Group description not limited by UI
Status: CLOSED DUPLICATE of bug 826224
Product: JBoss Operations Network
Classification: JBoss
Component: UI, Usability (Show other bugs)
JON 3.0.0
All All
medium Severity low
: ---
: JON 3.1.2
Assigned To: Jirka Kremser
Mike Foley
:
Depends On:
Blocks: 860183
  Show dependency treegraph
 
Reported: 2012-02-09 09:40 EST by Rafael Chies
Modified: 2012-11-02 09:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 860183 (view as bug list)
Environment:
Last Closed: 2012-11-02 09:02:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Chies 2012-02-09 09:40:10 EST
When creating a compatible group, the description text area let me free to type more than 100 chars. However, there is a limit on RHQ_RESOURCE_GROUP table. This cause a not friendly exception message to the end user.


Steps to Reproduce:
1. Try create a new compatible group
2. Type a description greater than 100 chars.
3. Choose the group members and click finish
  
Actual results:
A not friendly exception message appears to end user


Expected results:
A limitation on the UI text area, or more friendly error message.
Comment 1 Jirka Kremser 2012-05-24 07:03:47 EDT
http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=ead694e

git log
-------
time:    Thu May 24 12:57:50 2012 +0200
commit:  ead694e1a3b5ebdf540e21f9f4fe8a50703760fc
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 788997] Setting the maximum length of the description to 100 characters
Comment 2 Jirka Kremser 2012-09-25 04:29:20 EDT
this one ^^ was the commit to the master branch

It's fixed in the master (ead694e) and it needs to be cherry-picked once the release branch is ready for accepting the 3.1.2 commits.
Comment 3 Charles Crouch 2012-11-01 10:57:25 EDT
Setting to medium priority as we shouldn't showing exceptions to users.
Comment 4 Jirka Kremser 2012-11-02 09:02:44 EDT
fixed by ce91771299e. Bug 826224 is a duplicate.

*** This bug has been marked as a duplicate of bug 826224 ***

Note You need to log in before you can comment on or make changes to this bug.