Bug 789037 - ISE when scheduling KS on system with virbr0-nic interface
ISE when scheduling KS on system with virbr0-nic interface
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zazrivec
Martin Minar
:
Depends On: 788988
Blocks: sat550-post-ga/sat550-test-blockers sat550-ipv6
  Show dependency treegraph
 
Reported: 2012-02-09 11:18 EST by Milan Zazrivec
Modified: 2016-07-03 20:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: cobbler-2.0.7-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 788988
Environment:
Last Closed: 2012-10-19 06:09:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch (625 bytes, patch)
2012-02-09 11:25 EST, Milan Zazrivec
no flags Details | Diff

  None (edit)
Description Milan Zazrivec 2012-02-09 11:18:46 EST
Cloning for the cobbler fix as well.

+++ This bug was initially created as a clone of Bug #788988 +++

Description of problem:
I have system with multiple interfaces and I see ISE when I try to schedule KS on it.


Version-Release number of selected component (if applicable):
cobbler-2.0.7-15.el5sat
spacewalk-java-1.6.102-1.el5
tomcat5-5.5.23-0jpp.22.el5_7


How reproducible:
1 of 1


Steps to Reproduce:
1. Have system with interfaces as mentioned below
2. Register it to SW, add provisioning and attempt to schedule KS on it with "Schedule Kickstart and Finish"


Actual results:
ISE displayed


Expected results:
Should work


Additional info:
Client:
# ip a l
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:10:18:48:2c:63 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:23:7d:4c:9f:05 brd ff:ff:ff:ff:ff:ff
    inet 10.34.27.51/23 brd 10.34.27.255 scope global eth1
    inet6 2620:52:0:221b:223:7dff:fe4c:9f05/64 scope global dynamic 
       valid_lft 2591970sec preferred_lft 604770sec
    inet6 fe80::223:7dff:fe4c:9f05/64 scope link 
       valid_lft forever preferred_lft forever
4: virbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN 
    link/ether 52:54:00:27:41:b0 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
5: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 500
    link/ether 52:54:00:27:41:b0 brd ff:ff:ff:ff:ff:ff


Server:
# tail /var/log/tomcat5/catalina.out
[...]
Caused by: org.cobbler.XmlRpcException: XmlRpcException calling cobbler.
        at org.cobbler.CobblerConnection.invokeMethod(CobblerConnection.java:120)
        at org.cobbler.CobblerConnection.invokeTokenMethod(CobblerConnection.java:150)
        at org.cobbler.SystemRecord.invokeModify(SystemRecord.java:167)
        at org.cobbler.CobblerObject.modify(CobblerObject.java:149)
        at org.cobbler.SystemRecord.setNetworkInterfaces(SystemRecord.java:377)
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerSystemCreateCommand.processNetworkInterfaces(CobblerSystemCreateCommand.java:328)
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerSystemCreateCommand.store(CobblerSystemCreateCommand.java:237)
        at com.redhat.rhn.manager.kickstart.KickstartScheduleCommand.store(KickstartScheduleCommand.java:597)
        at com.redhat.rhn.frontend.action.kickstart.ScheduleKickstartWizardAction.runThird(ScheduleKickstartWizardAction.java:488)
        ... 48 more
Caused by: redstone.xmlrpc.XmlRpcFault: exceptions.ValueError:too many values to unpack
        at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:443)
        at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
        at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
        at org.cobbler.CobblerConnection.invokeMethod(CobblerConnection.java:117)
        ... 56 more
2012-02-09 07:55:40,730 [TP-Processor1] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/rhn].[action] - Servlet.service() for servlet action threw exception
redstone.xmlrpc.XmlRpcFault: exceptions.ValueError:too many values to unpack
        at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:443)
[...]

# tailf /var/log/cobbler/cobbler.log
[...]
Thu Feb  9 08:30:24 2012 - INFO | find_items; ['system']
Thu Feb  9 08:30:24 2012 - INFO | Exception occured: exceptions.ValueError
Thu Feb  9 08:30:24 2012 - INFO | Exception value: too many values to unpack
Thu Feb  9 08:30:24 2012 - INFO | Exception Info:
  File "/usr/lib/python2.4/site-packages/cobbler/remote.py", line 1758, in _dispatch
    return method_handle(*params)
   File "/usr/lib/python2.4/site-packages/cobbler/remote.py", line 765, in modify_system
    return self.modify_item("system",object_id,attribute,arg,token)
   File "/usr/lib/python2.4/site-packages/cobbler/remote.py", line 758, in modify_item
    return method(arg)
   File "/usr/lib/python2.4/site-packages/cobbler/item_system.py", line 580, in modify_interface
    (field,interface) = key.split("-")
Thu Feb  9 08:31:00 2012 - INFO | REMOTE invalid token; user(???)
[...]

--- Additional comment from mzazrivec@redhat.com on 2012-02-09 11:13:26 EST ---

spacewalk.git master: 64f2fc93e9042e27aba1eba5444fcd981d0d08ca
Comment 1 Milan Zazrivec 2012-02-09 11:25:31 EST
Created attachment 560633 [details]
patch

Note You need to log in before you can comment on or make changes to this bug.