This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 789119 - dracut-015-1.fc17 generated initramfs makes it impossible to boot
dracut-015-1.fc17 generated initramfs makes it impossible to boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-09 16:03 EST by Michal Jaegermann
Modified: 2012-02-13 11:22 EST (History)
5 users (show)

See Also:
Fixed In Version: dracut-015-9.git20120213.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-13 05:13:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch (831 bytes, patch)
2012-02-10 06:43 EST, Harald Hoyer
no flags Details | Diff

  None (edit)
Description Michal Jaegermann 2012-02-09 16:03:55 EST
Description of problem:

After an update to dracut-015-1.fc17 and kernel-3.3.0-0.rc2.git6.1.fc17 all attempts to boot end up with "cannot find init" from dracut and in a dracut "debug shell".  'init' is there sitting as an executable /bin/sh script in the top directory if initrams.  Attempts to restart a machine from there fizzle with "Failed to talk to init daemon" errors.  If you will try in this debug shell run explicitely './init' then it starts going through motions and runs fsck on /sysroot/usr but eventually chokes with:

mount: can't find /sysroot/usr in /etc/fstab.

Actually /etc/fstab has only two identical lines, like this, in it:

LABEL=/usr1 /sysroot/usr ext3 defaults 1 2

and 'mount LABEL=/usr1 /sysroot/usr' or 'mount -L /usr1 /sysroot/usr' work just fine although 'mount /sysroot/usr' fails with "can't find".

The only things I was able to do in this moment was either power switch or a kernel panic after 'exit'.

Version-Release number of selected component (if applicable):
dracut-015-1.fc17

How reproducible:
always

Additional info:
Is this another instance of binutils bug 788107? An attempt to boot the same kernel with a dracut-014-77.git20120126.fc17.1 generated initramfs got stuck with a claim that 'init' is not executable and I did not get even a debug shell (which does not seem to be that useful anyway).
Comment 1 David Ward 2012-02-09 23:38:01 EST
Still broken in rawhide with dracut-015-7.fc18
Comment 2 Harald Hoyer 2012-02-10 06:43:07 EST
Created attachment 560879 [details]
Proposed patch

can you try the attached patch on /usr/lib/dracut/modules.d/98usrmount/mount-usr.sh ?
Comment 3 Michal Jaegermann 2012-02-10 13:10:05 EST
(In reply to comment #2)

> can you try the attached patch on
> /usr/lib/dracut/modules.d/98usrmount/mount-usr.sh ?

With initramfs generated by dracut-015-8.git20120210 + this patch my machine booted 3.3.0-0.rc2.git6.1.fc17.x86_64.  Thanks!
Comment 4 David Ward 2012-02-11 00:00:14 EST
Works for me too, please commit fix.
Comment 5 kevin martin 2012-02-11 09:54:50 EST
neither applying the patch nor rebuilding the initramfs has fixed the issue with me.  I opened a new bugzilla for this ( 789503 ) and will post updates there if I see anything more.
Comment 6 Harald Hoyer 2012-02-13 05:13:14 EST
dracut-015-9.git20120213.fc17
Comment 7 kevin martin 2012-02-13 11:22:27 EST
seems to have fixed it.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.