Bug 789133 - JON 3.01 RC3 1st letter of drift include directory is truncated on snapshot
JON 3.01 RC3 1st letter of drift include directory is truncated on snapshot
Status: CLOSED DUPLICATE of bug 789492
Product: RHQ Project
Classification: Other
Component: drift (Show other bugs)
3.0.1
Unspecified Linux
high Severity high (vote)
: ---
: JON 3.0.1
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-09 17:10 EST by Mike Foley
Modified: 2012-02-10 16:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-10 16:32:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
drift definition (note the directory name = "home/mfoley/..." (90.66 KB, image/png)
2012-02-09 17:11 EST, Mike Foley
no flags Details
drift snapshot (note the directory name = "ome/mfoley...." (59.15 KB, image/png)
2012-02-09 17:12 EST, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2012-02-09 17:10:36 EST
Description of problem: JON 3.01 RC3 1st letter of drift include directory is truncated on snapshot


Version-Release number of selected component (if applicable):  JON 3.01 RC3




Steps to Reproduce:
1.  create a drift defintion as follows:  detection interval =45.  base dir = /.  include dir = "home/mfoley/folderwatchedbyDrift".
2.  cause some drift.  wait for drift to be detected and snapshots created.
3.  observe directory name on snapshot <> directory name in definition ...the 1st letter is truncated.
  
Actual results:  1st letter of directory is missing


Expected results:  directory name is consistent between drift definition and drift snapshot on carousel view.


Additional info:  see attached 2 images.  the 1st shows the include directory to be "home/mfoley/folderwatchedbyDrift" ... the 2nd image shows the snapshot where the directory is "ome/mfoley...."  (the "h" is missing)
Comment 1 Mike Foley 2012-02-09 17:11:29 EST
Created attachment 560720 [details]
drift definition (note the directory name = "home/mfoley/..."
Comment 2 Mike Foley 2012-02-09 17:12:16 EST
Created attachment 560721 [details]
drift snapshot (note the directory name = "ome/mfoley...."
Comment 3 Mike Foley 2012-02-09 17:17:46 EST
note:  i am on linux.  jshaughn cannot repro on windows.  this may be platform specific ...
Comment 4 Jay Shaughnessy 2012-02-10 16:32:27 EST

*** This bug has been marked as a duplicate of bug 789492 ***

Note You need to log in before you can comment on or make changes to this bug.