Bug 789150 - SGE integration broken in openmpi-1.5.3
SGE integration broken in openmpi-1.5.3
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openmpi (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jay Fenlason
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-09 18:19 EST by Joshua Baker-LePain
Modified: 2014-08-31 19:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 16:50:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Baker-LePain 2012-02-09 18:19:34 EST
Description of problem:
OpenMPI automatically detects when it is running under SGE (aka gridengine) and uses qrsh to launch remote tasks rather than ssh.  This integration is broken in 1.5.3 as included in 6.2.

Version-Release number of selected component (if applicable):
openmpi-1.5.3-3

How reproducible:
Every time.

Steps to Reproduce:
1. Launch an OpenMPI-1.5.3 program using SGE
2.
3.
  
Actual results:
OpenMPI attemts to use ssh

Expected results:
OpenMPI uses qrsh

Additional info:
Upstream claims this was fixed in 1.5.4.  See <https://svn.open-mpi.org/trac/ompi/ticket/2763>.
Comment 2 RHEL Product and Program Management 2012-05-03 01:35:43 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Jay Fenlason 2012-06-04 15:06:53 EDT
It looks like this should be fixed by the OpenMPI upgrade in Red Hat Enterprise Linux 6.3.  Can you test the 6.3 beta version and report whether this is still broken?
Comment 4 Joshua Baker-LePain 2012-06-05 16:36:42 EDT
That version does indeed fix it -- thanks!

Note You need to log in before you can comment on or make changes to this bug.