Bug 789226 - false presence of kernel headers in Fedora 16
false presence of kernel headers in Fedora 16
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-10 01:12 EST by abhidixit87
Modified: 2012-02-10 10:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-10 10:24:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description abhidixit87 2012-02-10 01:12:16 EST
Description of problem:
I am having a problem with respect to wireless card on my laptop.Dell Inspiron 1440.Card is 14e4:4315
The known methods on this planet from super cool dudes and Hin Min Chao's of the world after n number of discussions on forums here and there do not seem to work.Want to specially mention that the same hardware is working very very well with Ubuntu 11.10 installed on it (and Ubuntu is present there since its 9.04 release) I recently tried working with this thing known as Fedora.

yum install kernel-devel shows

Loaded plugins: langpacks, presto, refresh-packagekit
Repository google-chrome is listed more than once in the configuration
Setting up Install Process
Package kernel-devel-3.2.3-2.fc16.x86_64 already installed and latest version
Nothing to do

but if I download a driver from this page
http://www.broadcom.com/images/icons/zip_large.gif (given the same driver exists in rpmfusion repos)

and try to build it from scratch with instructions here
http://www.broadcom.com/docs/linux_sta/README.txt
upon doing a make I get 

 make
KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make: *** /lib/modules/3.1.0-7.fc16.x86_64/build: No such file or directory.  Stop.
make: *** [all] Error 2

but as I posted the kernel-devel is already installed.
uname -a
3.1.0-7.fc16.x86_64
I right now inside 
/lib/modules/3.1.0-7.fc16.x86_64
I see a folder name build 
 ls -l build 
lrwxrwxrwx. 1 root root 44 Nov  3 07:59 build -> ../../../usr/src/kernels/3.1.0-7.fc16.x86_64

but I can not for some reason compile the module from broadcom's site.




How reproducible:
Contact me I do not know how to explain it further.

Steps to Reproduce:
1.Only I can reproduce any body else in the world seems to be living happily ever after installing Fedora 16.
  
Actual results:
Things do not work.

Expected results:
My wireless should have worked


Additional info:
Check it out here
http://forums.fedoraforum.org/showthread.php?p=1553807&posted=1#post1553807
Comment 1 Josh Boyer 2012-02-10 10:24:30 EST
(In reply to comment #0)
> Description of problem:
> I am having a problem with respect to wireless card on my laptop.Dell Inspiron
> 1440.Card is 14e4:4315
> The known methods on this planet from super cool dudes and Hin Min Chao's of
> the world after n number of discussions on forums here and there do not seem to
> work.Want to specially mention that the same hardware is working very very well
> with Ubuntu 11.10 installed on it (and Ubuntu is present there since its 9.04
> release) I recently tried working with this thing known as Fedora.
> 
> yum install kernel-devel shows
> 
> Loaded plugins: langpacks, presto, refresh-packagekit
> Repository google-chrome is listed more than once in the configuration
> Setting up Install Process
> Package kernel-devel-3.2.3-2.fc16.x86_64 already installed and latest version
> Nothing to do

So here you downloaded kernel-devel-3.2.3-2.fc16.x86_64...

> but as I posted the kernel-devel is already installed.
> uname -a
> 3.1.0-7.fc16.x86_64

and here you're clearly running kernel 3.1.0-7.fc16.x86_64.  Which means anything relying on `uname -r` won't work.

Either boot into the 3.2.3 kernel and then rebuild, or install the kernel-devel package from the kernel you're running.

Note You need to log in before you can comment on or make changes to this bug.