Bug 78936 - Red Hat 8.0 Linux won't install on this laptop.
Red Hat 8.0 Linux won't install on this laptop.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-03 14:36 EST by Michael Waite
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 09:07:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Waite 2002-12-03 14:36:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Installer hangs even in text mode when trying to install 8.0 on Compaq Presario
906US.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Put in the cdrom and try to install in any mode.
2.
3.
	

Actual Results:  system hangs and num lock does not even light up.

Additional info:

Mandrake 9.0 hangs in similar manner, with "kernel panic" comment.
Comment 1 Dick Miller 2002-12-03 21:58:59 EST
This report was regarding MY Compaq 906US notebook computer -- as shown to Michael Waite earlier today. --Dick Miller
Comment 2 Arjan van de Ven 2002-12-06 15:08:06 EST
does this machine have an Radeon IGP chipset ?
Comment 3 Arjan van de Ven 2002-12-06 15:10:02 EST
using "linux nopcmcia ide=nodma nopcmcia isapnp=off nomce" 
might get the installation going if so, but it'll be a bumpy ride ;(
Comment 4 Dick Miller 2002-12-06 17:42:31 EST
Thanks for your response!

WinXP System Information says this Compaq 906US has an 
ATI Mobility U1graphics chip.  But that seems to be a YES, a relabelled Radeon IGP,
according to this article:
Compaq Presario 900 1500+: The Radeon IGP Goes Mobile:
http://www.anandtech.com/printarticle.html?i=1679
"the Radeon IGP 320M, labeled an ATI Mobility U1 chip"

That sounds promising.  I think I can test later tonight.

A further clue:
In SuSe Linux 8.1, it gets further than that when I Unload the Hardware
Driver for SCSI CD-ROM -- it's got an *IDE* Toshiba SD-R2312 CD-RW/DVD. 
But it gags later in the Install, with NO software options to select. 
Hmm.

Comment 5 Dick Miller 2002-12-06 20:03:40 EST
I've now tried to install using that line of code:
linux nopcmcia ide=nodma nopcmcia isapnp=off nomce

Blue screen for perhaps two minutes, then a text install that can't 
read the CD-ROM disc. No go. Other suggestions, please?
Comment 6 Alan Cox 2002-12-16 00:07:56 EST
Radeon IGP isn't supported in Linux
We don't have any documentation. It doesn't behave nicely when you drive it in
generic "unknown device" ways either. People are working on this and have the
radeonigp sort of working with test kernels now. Hopefully the next Red Hat
release will handle it.

I'm suprised the last one failed - that ought to work for an install. When you
say it couldnt find the CD did it see the cd-rom drive during boot ?
Comment 7 Dick Miller 2002-12-24 23:30:44 EST
Thank you!  Guess I'll have to wait a while to see any Radeon IGP video 
speed-up under Linux.

I'm back, and with a little progress to report.

This Compaq 906US computer now is booting in RHLinux 8.0, with "linux nopcmcia 
ide=nodma nopcmcia" automated early in the boot-up, and with me typing in a, 
then " nomce" when prompted by the grub boot-loader.  My attempts to edit the 
"nomce" into grub.conf haven't yet found a working combination.  (It's 
currently placed at the end of the "Title Red Hat Linux" lines, but that still 
results in the "kernel panic" lock-up unless I also hit "a" in time and then 
enter it manually.)

Although the built-in CD-RW/DVD-ROM combo drive and my Belkin Wireless PC Card 
work fine under WinXP, I can't run them in Linux.  Have yet to succeed with 
xine, or to back up.  Would love to get back the edge-scrolling feature of the 
computer's Syntactics touch pad.  Etc.

I don't yet have a functional computer under Linux, but hopefully it's getting 
there.  Holiday greetings to all.
Comment 8 Dick Miller 2002-12-26 13:36:46 EST
Two days ago I reported:
"My attempts to edit the "nomce" into grub.conf haven't yet found a working 
combination.  (It's currently placed at the end of the "Title Red Hat Linux" 
lines, but that still results in the "kernel panic" lock-up unless I also hit 
"a" in time and then enter it manually.)"

Minor progress:
Placing "nomce" at the end of the FIRST "Title Red Hat Linux" line does succeed 
in automating THAT step.  Now for the rest of my list...

Note You need to log in before you can comment on or make changes to this bug.