Bug 78939 - In some fonts, all characters are rendered as dotted squares
In some fonts, all characters are rendered as dotted squares
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-03 15:26 EST by John Klingler
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-10 14:17:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RealPlayer configuration dialog (33.75 KB, image/png)
2002-12-03 18:35 EST, John Klingler
no flags Details
Mr Project "About" information pop-up (5.95 KB, image/png)
2002-12-03 18:39 EST, John Klingler
no flags Details

  None (edit)
Description John Klingler 2002-12-03 15:26:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Characters in some pull down menus, information popups and command 
buttons that worked fine in Red Hat 7.2 now appear as dotted squares.

Applications like nedit get font errors like "Cannot convert string 
"FONTLIST" to type FontStruct". 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download and install rp8_linux20_libc6_i386_cs2.rpm from 
  http://scopes.real.com/real/player/unix/unix.html
2.In the KDE desktop menu, select programs->applications->Mr Project.
  When it starts, select the Help->About button and look at the text
  in the Copyright pop-up.
3.
	

Actual Results:  All the characters in some of the fonts are rendered as dotted
squares.

Expected Results:  All the characters in all the fonts should be rendered correctly.

Additional info:

I am using the X11R6.4 server from the X Consortium, not XFree86.
These are the supported extensions (no GLX).
number of extensions:    15
    BIG-REQUESTS
    DOUBLE-BUFFER
    Extended-Visual-Information
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RECORD
    SECURITY
    SHAPE
    SYNC
    TOG-CUP
    XC-MISC
    XJupiter
    XTEST
    XTestExtension1
    XVideo
Comment 1 John Klingler 2002-12-03 18:35:11 EST
Created attachment 87284 [details]
RealPlayer configuration dialog
Comment 2 John Klingler 2002-12-03 18:39:24 EST
Created attachment 87285 [details]
Mr Project "About" information pop-up
Comment 3 John Klingler 2002-12-03 19:14:24 EST
I put a breakpoint in the X Server and intercepted all the font requests
coming from Real Player 8. The fonts were successfully opened and appeared
normal with showfont and when passed to an xterm:
"cursor"
"Fixed"
"fixed"
"-adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*"

The problem is elsewhere. These are the libs used by Real Player 8:
ldd /usr/bin/X11/realplay
        libXp.so.6 => /usr/X11R6/lib/libXp.so.6 (0x4002c000)
        libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x40034000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40049000)
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x40056000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x400a2000)
        libm.so.6 => /lib/i686/libm.so.6 (0x40177000)
        libdl.so.2 => /lib/libdl.so.2 (0x40199000)
        libpthread.so.0 => /lib/i686/libpthread.so.0 (0x4019d000)
        libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x401b1000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x401b9000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

The only libraries Real Player 8 has in common with Mr Project are:
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40049000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x400a2000)
        libm.so.6 => /lib/i686/libm.so.6 (0x40177000)
        libdl.so.2 => /lib/libdl.so.2 (0x40199000)
        libpthread.so.0 => /lib/i686/libpthread.so.0 (0x4019d000)
        libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x401b1000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x401b9000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

Another peculiarity is that on a system on which I did a complete installation
of Red Hat 7.3, if you start mrproject from the command line, the fonts in the
"About" information box render correctly. With realplay, the fonts are screwed
up no matter how you start it.
Comment 4 Mike A. Harris 2002-12-04 19:20:01 EST
Let me see if I understand this correctly...  You are using software that
is not supplied by Red Hat (X.org X11R6.4), having a problem with a
proprietary software application (realplay) to which the source code
isn't even available, and you are filing a bug report in Red Hat's bug
tracking system?

You do realize that bugzilla is for reporting bugs in Red Hat supplied
software ONLY.  It is not a random place for reporting bugs in whatever
software you happen to install on your system yourself.  Sorry, but this
bug report is inappropriate here.

Closing NOTABUG.
Comment 5 John Klingler 2002-12-09 15:49:24 EST
I understand your objections, however, Nedit is part of the Red Hat 7.3 
release and the FONTLIST problem also occurs on a laptop running Red Hat 
7.3 and XFree86. Mr. Project is also part of the 7.3 distribution. You might at 
least have looked at those. 
Comment 6 Mike A. Harris 2002-12-09 18:36:12 EST
No, that isn't the way it works.  You've replaced half of your operating
system with software that does not ship with Red Hat Linux, and therefore,
your entire OS installation is 100% totally unsupported by Red Hat.

If you have a problem with the XFree86 release that ships with the OS,
and can reproduce the problems that you have encountered above by using
Red Hat supplied software, then you can file bug reports against XFree86.

You are using X.org, and not XFree86.  If nedit and other software has
problems under official Red Hat LInux installation, then you can file
individual bug reports against nedit and whatever other software you
encounter problems with.  This is however definitely not an XFree86
issue as it stands now, and it is not supported by Red Hat.

If we were to spend our time troubleshooting user reported problems like
this, we would largely be wasting our time tracking down bugs in other
people's software, and user's weird custom setups.  There is a line
between what we support and what we do not support.

We do not support X.org X installations.  Do a fresh installation of
Red Hat Linux 7.3 and update it to the current erratum.  If you can
reproduce these problems you mention above, without having replaced
any parts of the operating system, then by all means file bug reports
against nedit and mrproject.
Comment 7 John Klingler 2002-12-10 14:17:43 EST
Please read what I wrote: "Nedit is part of the Red Hat 7.3 release and the
FONTLIST problem also occurs on a laptop running Red Hat  7.3 and XFree86. " 
This laptop is a straight install of RH 7.3 using the XFree86 X Server. 

No third party software. Forget the other system.
Comment 8 Mike A. Harris 2002-12-11 13:26:48 EST
dotted squares are the "default" character for characters that do not
exist in the fonts that you are using.  These are not bugs.

Install the fonts that contain the characters that are trying to be
displayed and the characters should then display.

I see _no_ XFree86 bug here.  File a bug against nedit if you think
there is a bug in nedit.  I'll also note that I've started both nedit
and Mr. Project and both work perfectly fine for me.  In order to
consider this a bug in anything, you'll need to provide complete
specific instructions on how to reproduce this 100% of the time on
any Red Hat Linux box.  It doesn't happen on my box.
Comment 9 John Klingler 2002-12-11 15:34:02 EST
Nedit "works fine" for me, too. However, when starting up, it encounters a
problem with
the font object it receives from the Xfree86 libraries and outputs the message I
quoted:

    "Cannot convert string "FONTLIST" to type FontStruct"

Perhaps you were not starting it from the command line, so you missed the error
message.
(If you start it as root, the message is "Cannot convert string "%s" to type
%sTh".)
The  fact that nedit is well-written and has an intelligent fallback doesn't
mean there is
not a bug in the client libraries, probably an ad hoc change to the X protocol.

Comment 10 John Klingler 2002-12-11 16:52:56 EST
By the way, it is amusing to note that the original bug, "Characters in some
pull down menus,
information popups and command buttons that worked fine in Red Hat 7.2 now
appear as dotted
squares." appears in my previous comment at the end of the sentence "(If you
start it as root, ...)
i.e.: %sT%

I think I have an idea what might be causing this. Try highlighting the box
characters and ascii
text appears. That looks like attribute bits are being set.

Note You need to log in before you can comment on or make changes to this bug.