Bug 789410 - ruby 1.9.3 is FTBFS on ARM platforms
Summary: ruby 1.9.3 is FTBFS on ARM platforms
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeroen van Meeuwen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2012-02-10 17:42 UTC by Peter Robinson
Modified: 2012-06-15 08:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 08:00:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Robinson 2012-02-10 17:42:51 UTC
version: ruby-1.9.3.0-7.fc17

Looks like it's segfaulting in one of the tests.

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=373723

./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems "./test/runner.rb" --ruby="./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems" 
/builddir/build/BUILD/ruby-1.9.3-p0/lib/rdoc/task.rb:322: warning: already initialized constant RDocTask
Run options: "--ruby=./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems"
# Running tests:
..........................................................................................................................................................................................................F..................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................zero and implicit precision is deprecated.
........................................................................................................................................................................................................................................................................................................................................................................................................................DB->del: attempt to modify a read-only database
.............................DB->put: attempt to modify a read-only database
..........................................................................................................................S.SSS.S.SSSSSSSSSSSSSSSSSSSS......................S....S.........................................................................................................................................................................................................................................................................................................................................................................................................................................................../builddir/build/BUILD/ruby-1.9.3-p0/lib/webrick/utils.rb:184: [BUG] Segmentation fault
ruby 1.9.3p0 (2011-10-30) [armv7hl-linux]
-- Control frame information -----------------------------------------------
c:0007 p:---- s:0017 b:0017 l:000016 d:000016 CFUNC  :resume
c:0006 p:0015 s:0014 b:0014 l:000bb0 d:0020b0 BLOCK  /builddir/build/BUILD/ruby-1.9.3-p0/test/ruby/test_fiber.rb:55
c:786428817 p:---- s:0011 b:-60909305 l:000100 d:000100 FINISH
c:0004 p:---- s:0009 b:0009 l:000008 d:000008 CFUNC  :times
c:0003 p:0011 s:0006 b:0006 l:000bb0 d:00164c BLOCK  /builddir/build/BUILD/ruby-1.9.3-p0/test/ruby/test_fiber.rb:54
c:0002 p:---- s:-60944928 b:0004 l:000003 d:000003 FINISH
c:0001 p:---- s:0002 b:0002 l:000001 d:000001 TOP   
make: *** [yes-test-all] Segmentation fault

Comment 1 Vít Ondruch 2012-02-13 12:23:04 UTC
I can't help I am afraid. Would you be able to support upstream with analysis of this problem?

Comment 2 Peter Robinson 2012-02-13 13:03:39 UTC
(In reply to comment #1)
> I can't help I am afraid. Would you be able to support upstream with analysis
> of this problem?

Not really, I expect the package maintainer to analyse it and report anything necessary or liaise with upstream as they should have some form of relationship with upstream to be able to deal with this.

Comment 3 Peter Robinson 2012-02-24 15:10:07 UTC
Any update on this?

Comment 4 Vít Ondruch 2012-02-24 15:18:00 UTC
Unfortunately not much. This is upstream bug I opened: https://bugs.ruby-lang.org/issues/6011

Comment 5 Vít Ondruch 2012-04-20 12:35:16 UTC
There seems to be more issues on ARM, upstream is looking for ARM maintainer: http://bugs.ruby-lang.org/issues/5780

Comment 6 Steve McIntyre 2012-06-06 05:11:44 UTC
We've seen the exact same problem in Debian and found a solution: see 

http://bugs.debian.org/652674

for more details.

Comment 7 Vít Ondruch 2012-06-06 12:01:48 UTC
Thank you Steve!

You are right. It works it seems. At least for Rawhide [1] (although there is one test failed, it is not the segfault at least). Going to test F17 now [2].

[1] http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=886988
[2] http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=887796


Note You need to log in before you can comment on or make changes to this bug.