Bug 789437 - SELinux is preventing /usr/libexec/evolution-addressbook-factory from 'name_connect' accesses on the None .
SELinux is preventing /usr/libexec/evolution-addressbook-factory from 'name_c...
Status: CLOSED DUPLICATE of bug 789422
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0c19b473b5e3c38468026a20dfc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-10 13:55 EST by Nicolas Mailhot
Modified: 2012-02-13 04:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-13 04:59:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2012-02-10 13:55:16 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc3.git0.2.fc18.x86_64
reason:         SELinux is preventing /usr/libexec/evolution-addressbook-factory from 'name_connect' accesses on the None .
time:           ven. 10 févr. 2012 19:47:33 CET

description:
:SELinux is preventing /usr/libexec/evolution-addressbook-factory from 'name_connect' accesses on the None .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that evolution-addressbook-factory should be allowed name_connect access on the  <Inconnu> by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep pool /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:ldap_port_t:s0
:Target Objects                 [ None ]
:Source                        pool
:Source Path                   /usr/libexec/evolution-addressbook-factory
:Port                          389
:Host                          (removed)
:Source RPM Packages           evolution-data-server-3.3.5-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-0.rc3.git0.2.fc18.x86_64 #1
:                              SMP Thu Feb 9 13:01:46 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    ven. 10 févr. 2012 19:36:41 CET
:Last Seen                     ven. 10 févr. 2012 19:36:41 CET
:Local ID                      c815e5d7-1083-4447-ae5f-8baa0e801b0c
:
:Raw Audit Messages
:type=AVC msg=audit(1328899001.291:205): avc:  denied  { name_connect } for  pid=2031 comm="pool" dest=389 scontext=unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023 tcontext=system_u:object_r:ldap_port_t:s0 tclass=tcp_socketnode=(removed) type=SYSCALL msg=audit(1328899001.291:205): arch=c000003e syscall=42 success=yes exit=0 a0=a a1=7f3d74001300 a2=10 a3=0 items=0 ppid=1 pid=2031 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=2 comm="pool" exe="/usr/libexec/evolution-addressbook-factory" subj=unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023 key=(null)
:
:
:Hash: pool,abrt_helper_t,ldap_port_t,None,name_connect
:
:audit2allow
:
:
:audit2allow -R
:
:
Comment 1 Miroslav Grepl 2012-02-13 04:59:08 EST

*** This bug has been marked as a duplicate of bug 789422 ***

Note You need to log in before you can comment on or make changes to this bug.