This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 789443 - (CVE-2012-0247, CVE-2012-0248) CVE-2012-0247 CVE-2012-0248 ImageMagick: invalid validation of images denial of service
CVE-2012-0247 CVE-2012-0248 ImageMagick: invalid validation of images denial ...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20120203,repor...
: Security
Depends On: 796843 796844 796845 797121 804787 804788
Blocks: 789444
  Show dependency treegraph
 
Reported: 2012-02-10 13:58 EST by Vincent Danen
Modified: 2015-11-24 09:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
upstream patch (11.91 KB, patch)
2012-02-10 14:00 EST, Vincent Danen
no flags Details | Diff
Better patch from upstream (13.40 KB, patch)
2012-03-01 13:31 EST, Stefan Cornelius
no flags Details | Diff

  None (edit)
Description Vincent Danen 2012-02-10 13:58:54 EST
Two input validation and denial of service flaws were reported [1],[2] in ImageMagick:

[CVE-2012-0247] When parsing a maliciously crafted image with incorrect offset and count in the ResolutionUnit tag in EXIF IFD0, ImageMagick copies two bytes into an invalid address.
[CVE-2012-0248] When parsing a maliciously crafted image with an IFD whose all IOP tags' value offsets point to the beginning of the IFD itself. As a result, ImageMagick parses the IFD structure indefinitely, causing a denial of service.

The patch (noted in the upstream report) fixes the flaw in magick/property.c, which exists in Fedora's versions of ImageMagick (6.6.5 and 6.7.0) and Red Hat Enterprise Linux 6 (6.5.4), however it does not exist in Red Hat Enterprise Linux 5 and earlier versions of ImageMagick (6.2.8).

[1] http://www.imagemagick.org/discourse-server/viewtopic.php?f=4&t=20286
[2] http://www.cert.fi/haavoittuvuudet/2012/haavoittuvuus-2012-021.html
Comment 1 Vincent Danen 2012-02-10 14:00:55 EST
Created attachment 560951 [details]
upstream patch
Comment 3 Stefan Cornelius 2012-02-23 13:31:38 EST
Created ImageMagick tracking bugs for this issue

Affects: fedora-all [bug 796843]
Comment 5 Stefan Cornelius 2012-02-24 05:38:30 EST
Created GraphicsMagick tracking bugs for this issue

Affects: fedora-all [bug 797121]
Comment 8 Stefan Cornelius 2012-03-01 13:31:54 EST
Created attachment 566909 [details]
Better patch from upstream

The previous patch was not complete. This is a newer patch from upstream, which should fix the issues completely.

Olivier: This will likely also obsolete your patch, but I didn't
investigate that any further.
Comment 14 errata-xmlrpc 2012-05-07 14:34:57 EDT
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2012:0545 https://rhn.redhat.com/errata/RHSA-2012-0545.html
Comment 15 errata-xmlrpc 2012-05-07 14:51:24 EDT
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2012:0544 https://rhn.redhat.com/errata/RHSA-2012-0544.html

Note You need to log in before you can comment on or make changes to this bug.