Bug 789595 - kernel 3.2.5-3.fc16.x86_64/X53S/K53SV iwlwifi connects at 1/4 speed of 802.11N compared against ath9k
kernel 3.2.5-3.fc16.x86_64/X53S/K53SV iwlwifi connects at 1/4 speed of 802.11...
Status: CLOSED DUPLICATE of bug 785561
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-11 11:17 EST by shamim.islam
Modified: 2012-02-13 10:19 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-13 10:19:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shamim.islam 2012-02-11 11:17:18 EST
Description of problem: iwlwifi driver does not connect with 802.11N throughput even when AP is set to N-only connections.


Version-Release number of selected component (if applicable):
3.2.5-3.fc16.x86_64

How reproducible: Constant/Always

This is an evolution of bug https://bugzilla.redhat.com/show_bug.cgi?id=785561 - the iwlwifi connection does not drop any longer but the performance is almost unusable.

Steps to Reproduce:
1. Start laptop w/ iwlwifi, WPA-PSK connection to 802.11N AP
2. Start laptop w/ ath9k, WPA-PSd conenction to same 802.11N AP 
3. Review connection details or run speed test
  
Actual results:
iwlwifi reports 1MB/s at rest, 45MB/s while transmitting
ath9k reports 150MB/s always

Expected results:
iwlwifi reports 1MB/s at rest, 150MB/s while transmitting
OR
iwlwifi reports 150MB/s always

Additional info:

There is definitely something going on with the iwlwifi driver. I have my HP
laptop (Phenom II 3GHz) using the ath9k driver running the same kernel as my
X53 ASUS (Core i7, 2.9GHz w/ Turbo) using the iwlwifi driver.

Both are connecting to the same AP. iwlwifi connects at 54MB max and drops to
1MBit regularly. Ath9k reports a steady 150MBit connection. The AP is
configured for 802.11N (WPA-PSK).

Speedtest.net shows similar results. the ath9k downloads at around 20-22MB, and
uploads around 1.5MB. The iwlwifi downloads at 5-6MB, and uploads at 1.5MB. The
upload speed is artificially throttled by my cable company. The download speeds
should be identical.

So now what? Any additional information I can provide that can help track down
the problem? The iwlwifi should not be connecting so slow for sure.
Comment 1 John W. Linville 2012-02-13 09:58:32 EST
Many factors influence performance, including which exact pieces of hardware are involved.  It is not always correct to presume that one ".11n" device is the same as another.

Please post the output of running "lspci -nv" on our iwlwifi-equipped box.
Comment 2 John W. Linville 2012-02-13 10:19:54 EST

*** This bug has been marked as a duplicate of bug 785561 ***

Note You need to log in before you can comment on or make changes to this bug.