Bug 789708 - Hibernating fails at all
Hibernating fails at all
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-02-12 08:26 EST by Mike Heller
Modified: 2012-12-13 05:52 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 05:52:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg-output (67.46 KB, text/plain)
2012-02-12 08:26 EST, Mike Heller
no flags Details
pm-utils-bugreport-info (7.83 KB, text/plain)
2012-02-12 08:27 EST, Mike Heller
no flags Details
pm-utils-bugreport-info - orca (8.70 KB, text/plain)
2012-02-14 12:54 EST, Orion Poplawski
no flags Details
dmesg output kernel 3.6.2-4 (61.34 KB, text/plain)
2012-10-24 13:35 EDT, Mike Heller
no flags Details

  None (edit)
Description Mike Heller 2012-02-12 08:26:34 EST
Created attachment 561216 [details]
dmesg-output

Description of problem:

Hibernating hangs all time since kernel 3.2.x
It's pretty annoying.


Version-Release number of selected component (if applicable):

kernel-3.2.5-3

How reproducible:

try to hibernate the computer


Steps to Reproduce:
1. e.g. either pm-hibernate via console or via gnome-shell
2.
3.
  
Actual results:
system hangs.
only a reboot via magic keys possible.


Expected results:

hibernation of the computer and succesfull resume


Additional info:
Comment 1 Mike Heller 2012-02-12 08:27:31 EST
Created attachment 561217 [details]
pm-utils-bugreport-info
Comment 2 Orion Poplawski 2012-02-14 12:54:38 EST
Created attachment 561998 [details]
pm-utils-bugreport-info - orca

Me too.
Comment 3 Mike Heller 2012-02-25 09:10:15 EST
problem still exists in kernel 3.2.7.
Please investatigate. It's very annoying.
Comment 4 aaronsloman 2012-02-27 18:32:40 EST
This seems to be a duplicate of 
https://bugzilla.redhat.com/show_bug.cgi?id=785384
Comment 5 Dave Jones 2012-03-22 12:54:12 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 6 Dave Jones 2012-03-22 12:57:49 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 7 Dave Jones 2012-03-22 13:09:01 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 8 Mike Heller 2012-03-26 16:11:51 EDT
hibernating will not hang anymore but still a lot of troubles.

updated my desktop on friday an observed the behaviour over the weekend.
Actually I did also some testing with hibernating several times manually.

I saw several failures:

most of the time I go a "PM: LZO decompression failed/"Invalid LZO uncompressed length" and the machine booted instead of resuming.

on the other hand I got some kernel panics which I cannot post here. ( could not find anywhere on logs )

and sometimes call traces like this:

Mar 26 19:25:49  kernel: [ 8858.103137] Call Trace:
Mar 26 19:25:49  kernel: [ 8858.103154]  [<c058f530>] ? dquot_quota_off+0x20/0x20
Mar 26 19:25:49  kernel: [ 8858.103178]  [<c056dce7>] __sync_filesystem+0x87/0x90
Mar 26 19:25:49  kernel: [ 8858.103202]  [<c056dd07>] sync_one_sb+0x17/0x20
Mar 26 19:25:49  kernel: [ 8858.103226]  [<c0549c38>] iterate_supers+0xb8/0xc0
Mar 26 19:25:49  kernel: [ 8858.103249]  [<c056dcf0>] ? __sync_filesystem+0x90/0x90
Mar 26 19:25:49  kernel: [ 8858.103274]  [<c056dd9f>] sys_sync+0x3f/0x60
Mar 26 19:25:49  kernel: [ 8858.103299]  [<c0951cdf>] sysenter_do_call+0x12/0x28
Mar 26 19:25:49  kernel: [ 8858.103323] Code: 00 00 00 00 39 c3 8d b0 68 ff ff ff 75 1a eb 6c 8d 74 26 00 80 07 01 8b 86 98 00 00 00 39 45 bc 8d b0 68 ff ff ff 74 54 8d 7e 4c <8b> 5e 20 89 f8 e8 47 30 3e 00 f6 46 64 38 75 d9 8b 43 3c 85 c0
Mar 26 19:25:49  kernel: [ 8858.103704] EIP: [<c0567aff>] sync_inodes_sb+0xbf/0x150 SS:ESP 0068:ee7f9f20
Mar 26 19:25:49  kernel: [ 8858.103743] CR2: 00000000ffffff89
Mar 26 19:25:49  kernel: [ 8858.103761] ---[ end trace 94ea8aff47ec29aa ]---



However, I have also a desktop in the office with not troubles at all!!
Comment 9 aaronsloman 2012-03-26 17:25:30 EDT
(In reply to comment #8)
> I saw several failures:
> 
> most of the time I go a "PM: LZO decompression failed/"Invalid LZO uncompressed
> length" and the machine booted instead of resuming.

I have had a problem with resume turning into reboot at a late stage on both my desktop and my laptop machines, both with intel core i5 CPU and intel graphics (requiring i915 module).

In both cases the resuming works fine if I have a separate menu entry for 'resume' in /boot/grub2/grub.cfg which is identical with the boot menu except for "acpi=off" in the 'linux' line.

I have been advised to report this as a separate bug, and will do so shortly. It would be useful to know if that extra flag also removes your resume failures.
See Bug #781749 Comment 85.

> on the other hand I got some kernel panics which I cannot post here. ( could
> not find anywhere on logs )

It's possible that your problem is different from the one cured by "acpi=off".
I also had such errors which turned out to be caused by 'yum update' inserting the wrong root partition ID for the new kernel in grub.cfg. It used the ID for the root partition for an earlier installation of Fedora 15. It seems that grubby has a very serious flaw, reported as Bug #756559 (and elsewhere).

If that is your problem you can edit grub.cfg by hand to use the same root=UUID=*** entry as worked previously.

Alternatively re-generate the file using the command recommended in Comment 12 of bug #756559, i.e. "grub-mkconfig -o /boot/grub2/grub.cfg"

You may need to check that it inserts the right boot flags for you.

(I just do the edit by hand, as older grub.cfg entries in the file have the correct UUID, in my case.)

Apologies if that's not your problem -- I mention it only because was totally mystified by serious errors after upgrading, until I realised I had booted using the wrong root partition. Thats a terribly serious bug (in grubby?) that urgently needs to be fixed, though it may not affect people who use a fresh install of Fedora on a new drive.

If you have upgraded to kernel 3.3.0-4 it would be interesting to know if your boot logs also include the message I've reported in Comment 84 in bug #781749
namely:
ata2: link is slow to respond, please be patient (ready=0)
Comment 10 Josh Boyer 2012-03-28 14:01:38 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.
Comment 11 Mike Heller 2012-04-11 01:37:26 EDT
just a small feedback:

since 11 days and the usage of kernel 3.3.0-7 my computer never hanged up during hibernation and allways thawed fine! ( that's arround 50 cycles )
Comment 12 Dave Jones 2012-10-23 11:39:21 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 13 Mike Heller 2012-10-24 13:33:59 EDT
resume from hibernation fails with latest kernel 3.6.2-4.fc17.i686.PAE with message in dmesg output:

PM: Hibernation image not present or could not be loaded.
Comment 14 Mike Heller 2012-10-24 13:35:20 EDT
Created attachment 632905 [details]
dmesg output kernel 3.6.2-4

Note You need to log in before you can comment on or make changes to this bug.