Bug 789765 - Cannot switch back to other input languages after using Arabic Input
Cannot switch back to other input languages after using Arabic Input
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-12 16:32 EST by k-hon
Modified: 2012-03-13 22:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 22:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description k-hon 2012-02-12 16:32:37 EST
Description of problem:
When add the Arabic input layout into the ibus preferences GUI, and pressing alt-shift(L) to use the arabic input, the input is stuck into arabic and cannot switch to other languages inputs, neither by pressing alt-shift(L) combination, neither by using the GUI (keyboard icon in the panel), no effect happens. 
The other language (e.g. English) is highlighted, but the input continues to be in arabic. 
Actually, even after removing the arabic input, there is no effect.
The only way to go back to English is by logging out of the system

Version-Release number of selected component (if applicable):
IBUS 1.4.0

How reproducible:
always


Steps to Reproduce:
1.right click on iBus icon in the panel, add language: Arabic
2.use key combination (Alt-Shift(L)) to switch to arabic, type in arabic
3.now try to switch back to english it doesn't work
  
Actual results:
input remains in arabic

Expected results:
keyboard input switches to other languages available

Additional info:
none
Comment 1 fujiwara 2012-02-23 04:12:43 EST
I cannot reproduce your problem.
Did you use the latest ibus?

# yum install ibus

Note You need to log in before you can comment on or make changes to this bug.