Bug 78993 - XFree86-4.2.99.2-0.20021126.4 problem with 3dfx banshee
XFree86-4.2.99.2-0.20021126.4 problem with 3dfx banshee
Status: CLOSED DUPLICATE of bug 79069
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-04 09:27 EST by Need Real Name
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-05 05:18:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XF86Config but probably unuseful (3.21 KB, text/plain)
2002-12-04 09:29 EST, Need Real Name
no flags Details
lspci -vxx output (4.42 KB, text/plain)
2002-12-04 09:32 EST, Need Real Name
no flags Details
mozilla 1.2.1 strace output (177.98 KB, text/plain)
2002-12-05 05:15 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-12-04 09:27:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2) Gecko/20021202

Description of problem:
All XFree86-4.2.99.2-0.20021126 releases .1, .3 & .4 from Mike Harris have a big
problem with my 3dfx banshee card (not tested on another card so can't say if
it's driver related). It crashs all browser like mozilla, opera and Instant
messenger like official closed source Yahoo Messenger.
It can be cvs from 20021126 related because
XFree86-4.2.99.2-0.20021122.2.src.rpm is OK.

Both tested with pre-compiled RPM from mharris and rebuild from .src.rpm.

Installation where done with mharris recommandation, I mean all rpm installd.

How reproducible:
Always

Steps to Reproduce:
1.rpm -e `rpm -qa|grep XFree"` --nodeps
2.rpm -ivh
ftp://people.redhat.com/mharris/testing/extremely-unstable-development-code/XFree86/4.2.99.2-0.20021126.4/i386/*.rpm
3.restart X
	

Actual Results:  X start successfully with no errors in /var/log/XFree86.0.log
but when starting mozilla, Yahoo messenger or Opera, they crash immediately.

Expected Results:  like XFree86-4.2.99.2-0.20021122.2.src.rpm: no problem to
start these software.
Comment 1 Need Real Name 2002-12-04 09:29:49 EST
Created attachment 87344 [details]
XF86Config but probably unuseful
Comment 2 Need Real Name 2002-12-04 09:32:33 EST
Created attachment 87345 [details]
lspci -vxx output
Comment 3 Mike A. Harris 2002-12-04 19:30:17 EST
If it is applications that are crashing, and not X itself, then you
need to provide a backtrace or something from the applications themselves
to find out why they are crashing.  Try an strace of a failing app.
Comment 4 Need Real Name 2002-12-05 05:15:11 EST
Created attachment 87464 [details]
mozilla 1.2.1 strace output
Comment 5 Need Real Name 2002-12-05 05:17:31 EST
these strace output were tested with 4.2.99.2-0.20021126.7.
same problem.

also opera crash with:
/usr/bin/opera: line 130:  1435 Erreur de segmentation  ${OPERA} "${@}"

I can't logout from Gnome and I can't Ctrl+Alt+1 to return to getty
Comment 6 Mike A. Harris 2002-12-05 07:51:58 EST
Closing as dupe of newer bug with backtrace.  Please see dupe report for
details.

*** This bug has been marked as a duplicate of 79069 ***
Comment 7 Need Real Name 2002-12-05 08:12:06 EST
Yes all my appliclations which crash depend on gtk & co lib.

But just another question concerning new XFree-4.2.99 unstables releases:

Do I need another package from rawhide to correct some problem with font
AntiAlising appeared since I switched to 4.2.99 ?

Note You need to log in before you can comment on or make changes to this bug.