Bug 79000 - Want network download and installation capability
Want network download and installation capability
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-04 10:07 EST by Taishin Kin
Modified: 2007-04-18 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 00:26:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Taishin Kin 2002-12-04 10:07:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
When new package is selected to be installed,
redhat-config-packages asks me to insert RedHat 8.0 CDROM.
However this tool will be more useful if it allows automatic download and
installation of the packages.
RPM does this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A

Actual Results:  N/A

Expected Results:  N/A

Additional info:

With the proposed download and installation capability, redhat-config-packages
completly replaces GnoRPM and becomes good competitor against LindowsOS's
ClickNRun, which helps RedHat to push into bigger desktop market :)
Comment 1 Michael Lee Yohe 2002-12-04 10:17:22 EST
This is already in Red Hat Linux (NOTABUG -- CURRENTRELEASE).

"up2date" allows you to do exactly that.  From the console, you can specify:

# up2date <package name>

up2date will query the Red Hat Network and install _all_ packages (including
dependencies) to satisfy your option.  For example:

# up2date gimp

The above command will install the Gimp and any required packages (including
GTK+ if not already installed) required to actually use the Gimp.

I have filed Bug 78610 because the graphical mode of up2date does not support
packages installation as it should.  So far, the bug has not been assigned.

I have also filed Bug 78608 to allows users to specify simply the program name,
allowing RHN to figure the package out and the dependencies associated with it.
Comment 2 Taishin Kin 2002-12-04 23:52:15 EST
But I'm talking about redhat-config-packages which does not have the 
capability what I mentioned.
Although up2date does it all and redhat-config-packages is a GUI frontend of 
it, this is not a matter of up2date GUI. It is a matter of redhat-config-
packages. Because redhat-config-packages should allow a user to choose whether 
he/she want to get packages from CD-ROM or RHN. After that, let the up2date do 
the job. IMO a minor modification to redhat-config-packages is sufficient.

Thanks.
Comment 3 Michael Lee Yohe 2002-12-05 00:57:04 EST
redhat-config-packages is not supposed to have the capability you mentioned -
that was MY point.  up2date already _HAS_ the capability.  Why move it to one
simple utility, the front-end to the packages stored on the CD, from the
front-end of the Red Hat Network (up2date)?

$ rpm -qi redhat-config-packages
<snip>
redhat-config-packages is the package manager for Red Hat Linux.  It
supports installation of interesting packages from CD.

When you initially install Red Hat Linux 8, it introduces you the concept of the
Red Hat Network (updates and installation) - therefore informing the user of the
existence of a network-install method for packages.  There are two interfaces to
RHN - up2date (application) and rhn.redhat.com (web).  Further segregating
interfaces is, in my opinion, non-intuitive.

Alternatively - a priority=ENHANCEMENT could be filed for redhat-config-packages
to allow a user to spawn up2date from the application to install packages _over
the network_.
Comment 4 Taishin Kin 2002-12-08 10:44:46 EST
My focus is on graphical interface that is very important for ordinary desktop
users.
redhat-config-packages has a very nice GUI for installing/removing packages. I
guess many users will find some packages they want to install but they just
can't do it without CD-ROM.
up2date also has very intuitive GUI but it just takes care of software update.
Althoug it is capable of arbitraly network-install, it doesn't offer any GUI.
So, for users who do not use the gnome-terminal, RedHat Network or up2date
simply means software update.
Ordinary users are not supposed to type a package name for command-line up2date
because they are not supposed to remember the package name at first hand. May be
they can check the package name by browsing redhat-config-packages then type the
name for command-line up2date.
But I highly doubt this is a good interface.
So "up2date has it already" thing has nothing to do with this issue.
I'm talking about a GUI issue.
Launching up2date from r-c-p is a quick solution because up2date developers do
not need to build another GUI for package selection which is already realized by
r-c-p.
Comment 5 Jeremy Katz 2002-12-31 02:41:39 EST
You can already point at installation trees and ISOs.  Adding support for
HTTP/FTP retrieval is on my todo list
Comment 6 Jeremy Katz 2003-01-02 01:55:12 EST
1.1.3 supports --tree={ftp,http}:// 
Comment 7 Jens Knutson 2003-09-22 12:31:25 EDT
The --tree flag is great, but IMHO, there ought to be some way to configure
r-c-p/up2date to use a specific tree or ISO dir by default, maybe via just a
basic config file in /etc?  Editing the .desktop file for up2date or r-c-p to
include command line arguments sucks. ;)
Comment 8 John Thacker 2006-04-22 00:26:05 EDT
Not going to be fixed, RH 8 not supported, and s-c-p isn't shipped anymore. 
(Pirut replaced s-c-p.)  Closing.

Note You need to log in before you can comment on or make changes to this bug.