Bug 790053 - F17-Branched 'GMountMountFlags' as enum when in fact it is of type 'GFlags'
F17-Branched 'GMountMountFlags' as enum when in fact it is of type 'GFlags'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pygobject2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-13 10:03 EST by Frank Murphy
Modified: 2012-07-02 18:27 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 18:27:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank Murphy 2012-02-13 10:03:19 EST
Description of problem: Gettin thia a lot with python based programes.

~]# system-config-services

** WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'
Couldn't acquire connection to systemd. Falling back to legacy SysV scheme.
Traceback (most recent call last):
  File "/sbin/system-config-services", line 1258, in <module>
    UIController(use_dbus=use_dbus).run()
  File "/sbin/system-config-services", line 1213, in __init__
    self.serviceherders.append(cls(bus=self._bus))
  File "/usr/lib/python2.7/site-packages/scservices/dbus/proxy/serviceherders.py", line 62, in __init__
    for service_name in self.list_services():
  File "<string>", line 2, in list_services
  File "/usr/lib/python2.7/site-packages/slip/dbus/polkit.py", line 141, in _enable_proxy
    return func(*p, **k)
  File "/usr/lib/python2.7/site-packages/scservices/dbus/proxy/serviceherders.py", line 74, in list_services
    return self.herder_interface.list_services()
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/slip/dbus/proxies.py", line 50, in __call__
    return dbus.proxies._ProxyMethod.__call__(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "list_services" with signature "" on interface "org.fedoraproject.Config.Services.ServiceHerder" doesn't exist
--------------------------------------------------

Another Example: 
system-config-users

** WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'
Traceback (most recent call last):
  File "/usr/share/system-config-users/system-config-users.py", line 44, in <module>
    mainWindow.mainWindow()
  File "/usr/share/system-config-users/mainWindow.py", line 267, in __init__
    self.groupTreeView, xml, selinuxEnabled)
  File "/usr/share/system-config-users/userWindow.py", line 58, in __init__
    self.userWinHomeDir.set_max_length(userGroupCheck.maxpathlength)
AttributeError: 'module' object has no attribute 'maxpathlength'


Version-Release number of selected component (if applicable):
dbus-1.4.10-4.fc17.x86_64
system-config-services-0.101.7-2.fc17.noarch
python-2.7.2-18.fc17.x86_64


How reproducible: Always, but only see the result on cli.


Steps to Reproduce:
1. In command terminal, type system-config-users\services
2.
3.
  
Actual results: Crash


Expected results: apps running.


Additional info:
Comment 1 Dave Malcolm 2012-02-13 12:29:12 EST
Thanks for filing this bug.

I tried reproducing this.  I started seeing these messages:

** WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

when running system-config-services after an update from:
  glib2-2.29.14-1.fc16.x86_64
to:
  glib2-2.31.16-1.fc17.x86_64

I don't see the other tracebacks reported in comment #0; I think they're individual bugs in the packages in question.

I'm reassigning this bug from the "python" component to "glib2" to cover the warning message above.  Given that system-config-services currently works for me with the above message I think it's unrelated to the tracebacks you're seeing.  If you continue to see Python tracebacks from the various system-config-* tools, please open separate bugs against the specific tools, with the specific tracebacks.   Thanks!
Comment 2 Matthias Clasen 2012-02-13 13:08:11 EST
-> pygobject
Comment 3 Jiri Popelka 2012-03-28 02:01:10 EDT
** (process:3767): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:3767): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:3767): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'


I see this with:
system-config-printer-1.3.9-1.fc17.x86_64
pygobject2-2.28.6-3.fc17.x86_64
package pygobject3 is not installed
glib2-2.31.22-1.fc17.x86_64
Comment 4 Joshua Covington 2012-04-15 09:37:32 EDT
Have you tried recompiling pygobjects2 with this patch: http://bugzilla-attachments.gnome.org/attachment.cgi?id=209543 ?
Comment 5 Joshua Covington 2012-04-15 09:38:30 EDT
Have you tried recompiling pygobjects2 with this patch: http://bugzilla-attachments.gnome.org/attachment.cgi?id=209543 ?
Comment 6 Mads Kiilerich 2012-04-25 17:36:51 EDT
(In reply to comment #4)

Yes, that solves the annoying warnings for me.

F17 scratch build at http://koji.fedoraproject.org/koji/taskinfo?taskID=4023184 .
Comment 7 Dennis Jacobfeuerborn 2012-06-12 18:29:57 EDT
This problem is still present in F17 final.
Comment 8 Dave Malcolm 2012-06-15 15:01:33 EDT
I've gone ahead and applied the patch to master:
  Building pygobject2-2.28.6-5.fc18 for dist-rawhide
  Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4168470

and to f17:
  Building pygobject2-2.28.6-5.fc17 for f17-candidate
  Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4168516

Both sets of builds succeeded.
Comment 9 Fedora Update System 2012-06-15 15:04:02 EDT
pygobject2-2.28.6-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pygobject2-2.28.6-5.fc17
Comment 10 Fedora Update System 2012-06-16 20:00:43 EDT
Package pygobject2-2.28.6-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pygobject2-2.28.6-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9576/pygobject2-2.28.6-5.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-07-02 18:27:39 EDT
pygobject2-2.28.6-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.