Bug 790190 - Invalid write in gtk3-3.2.3 causes crashes
Summary: Invalid write in gtk3-3.2.3 causes crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:950a01806bcc51dc88d7e42535c...
: 790011 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-13 21:09 UTC by Yann Droneaud
Modified: 2012-03-01 09:33 UTC (History)
5 users (show)

Fixed In Version: gtk3-3.2.3-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-01 09:33:58 UTC
Type: ---


Attachments (Terms of Use)
File: dso_list (21.87 KB, text/plain)
2012-02-13 21:09 UTC, Yann Droneaud
no flags Details
File: build_ids (8.01 KB, text/plain)
2012-02-13 21:09 UTC, Yann Droneaud
no flags Details
File: xsession_errors (2.83 KB, text/plain)
2012-02-13 21:09 UTC, Yann Droneaud
no flags Details
File: maps (95.49 KB, text/plain)
2012-02-13 21:09 UTC, Yann Droneaud
no flags Details
File: backtrace (68.17 KB, text/plain)
2012-02-13 21:09 UTC, Yann Droneaud
no flags Details
File: backtrace (63.67 KB, text/plain)
2012-02-13 21:19 UTC, Yann Droneaud
no flags Details
File: backtrace (91.78 KB, text/plain)
2012-02-15 07:14 UTC, Yann Droneaud
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 455900 0 None None None Never

Description Yann Droneaud 2012-02-13 21:09:17 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        evolution
comment:        Same thing as before: viewing send settings for an account and clicked on cancel
crash_function: __GI_raise
executable:     /usr/bin/evolution
kernel:         3.2.1-3.fc16.x86_64
pid:            19496
pwd:            /home/ydroneaud
reason:         Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
time:           lun. 13 févr. 2012 22:07:31 CET
uid:            1000
username:       ydroneaud

backtrace:      Text file, 69811 bytes
build_ids:      Text file, 8200 bytes
dso_list:       Text file, 22390 bytes
maps:           Text file, 97786 bytes
xsession_errors: Binary file, 2896 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:G_DEBUG=resident-modules,gc-friendly
:HOSTNAME=dworkin.quest-ce.net
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:CCACHE_SLOPPINESS=time_macros
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=f30222558c753b35ba5e60b900000007-1329120939.165239-2132557990
:GNOME_KEYRING_CONTROL=/tmp/keyring-cXZUCe
:IMSETTINGS_MODULE=none
:USER=ydroneaud
:G_SLICE=always-malloc,debug-blocks
:USERNAME=ydroneaud
:MAIL=/var/spool/mail/ydroneaud
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/ydroneaud/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/ydroneaud
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1497
:LANG=fr_FR.utf8
:GDM_LANG=fr_FR.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/ydroneaud
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=ydroneaud
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-NB9PGwnN6W,guid=53629aa230174e6fbdc3076b00000043
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/ydroneaud
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-ydroneaud-0djKBy/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1505,unix/unix:/tmp/.ICE-unix/1505
:SSH_AUTH_SOCK=/tmp/keyring-cXZUCe/ssh
:GPG_AGENT_INFO=/tmp/keyring-cXZUCe/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:DESKTOP_STARTUP_ID=gnome-shell-1729-dworkin.quest-ce.net-evolution-3_TIME20791496
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=19496

var_log_messages:
:Feb 13 12:41:11 dworkin kernel: [12400.278834] evolution[1898]: segfault at 0 ip 0000003dfae32817 sp 00007fffa85820b0 error 4 in libglib-2.0.so.0.3000.1[3dfae00000+11e000]
:Feb 13 12:41:13 dworkin abrt[8031]: Saved core dump of pid 1898 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-02-13-12:41:11-1898 (222707712 bytes)
:Feb 13 22:07:32 dworkin abrt[32694]: Saved core dump of pid 19496 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-02-13-22:07:31-19496 (240898048 bytes)

Comment 1 Yann Droneaud 2012-02-13 21:09:20 UTC
Created attachment 561680 [details]
File: dso_list

Comment 2 Yann Droneaud 2012-02-13 21:09:21 UTC
Created attachment 561681 [details]
File: build_ids

Comment 3 Yann Droneaud 2012-02-13 21:09:23 UTC
Created attachment 561682 [details]
File: xsession_errors

Comment 4 Yann Droneaud 2012-02-13 21:09:26 UTC
Created attachment 561683 [details]
File: maps

Comment 5 Yann Droneaud 2012-02-13 21:09:28 UTC
Created attachment 561684 [details]
File: backtrace

Comment 6 Yann Droneaud 2012-02-13 21:12:11 UTC
Same thing as bug #790011

Comment 7 Yann Droneaud 2012-02-13 21:19:46 UTC
Saving settings in the send/outgoing mail settings pane.

backtrace_rating: 4
Package: evolution-3.2.2-1.fc16
OS Release: Fedora release 16 (Verne)

Comment 8 Yann Droneaud 2012-02-13 21:19:49 UTC
Created attachment 561686 [details]
File: backtrace

Comment 9 Yann Droneaud 2012-02-13 21:22:25 UTC
In .xsession-errors, the message is:

GSlice: MemChecker: attempt to release non-allocated block: 0x5d1da20 size=40

Comment 10 Yann Droneaud 2012-02-13 21:29:55 UTC
I have the problem only with:

G_SLICE=always-malloc,debug-blocks
G_DEBUG=resident-modules,gc-friendly

Comment 11 Milan Crha 2012-02-14 10:03:27 UTC
*** Bug 790011 has been marked as a duplicate of this bug. ***

Comment 12 Milan Crha 2012-02-14 16:14:10 UTC
It seems to me that this is not an issue with Evolution. I was able to reproduce this, but with change from [1] it works as expected. Could you try with [2], which has the change included, whether it'll help for you too, please? Thanks in advance.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=455900
[2] http://koji.fedoraproject.org/koji/taskinfo?taskID=3790063

Comment 13 Yann Droneaud 2012-02-15 07:14:00 UTC
Settings -> Cancel

backtrace_rating: 4
Package: evolution-3.2.2-1.fc16
OS Release: Fedora release 16 (Verne)

Comment 14 Yann Droneaud 2012-02-15 07:14:03 UTC
Created attachment 562145 [details]
File: backtrace

Comment 15 Yann Droneaud 2012-02-15 07:35:41 UTC
(In reply to comment #12)
> It seems to me that this is not an issue with Evolution. I was able to
> reproduce this, but with change from [1] it works as expected. Could you try
> with [2], which has the change included, whether it'll help for you too,
> please? Thanks in advance.
> 
> [1] https://bugzilla.gnome.org/show_bug.cgi?id=455900
> [2] http://koji.fedoraproject.org/koji/taskinfo?taskID=3790063

I have installed the gtk proposed package (and the latest evolution package).

I'm not able to reproduce the bug currently.

Seems good for now.

Comment 16 Milan Crha 2012-02-15 08:02:18 UTC
Good, thanks for the update. I'll ask gtk+ maintainers to include the fix in the next update of gtk3.

Comment 17 Fedora Update System 2012-02-15 16:25:52 UTC
gtk3-3.2.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gtk3-3.2.3-2.fc16

Comment 18 Fedora Update System 2012-02-15 23:54:48 UTC
Package gtk3-3.2.3-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtk3-3.2.3-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1720/gtk3-3.2.3-2.fc16
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2012-03-01 09:33:58 UTC
gtk3-3.2.3-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.