This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 790239 - gnome-system-log depends on gnome-utils, which is obsoleted.
gnome-system-log depends on gnome-utils, which is obsoleted.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-system-log (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-02-13 20:21 EST by John Antony
Modified: 2014-01-21 18:21 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 18:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
access to log file denied (17.25 KB, image/png)
2012-03-19 22:46 EDT, Daniel Belton
no flags Details

  None (edit)
Description John Antony 2012-02-13 20:21:39 EST
Description of problem:
ERROR with transaction check vs depsolve:
gnome-utils = 1:3.2.1-1.fc17 is needed by gnome-system-log-1:3.2.1-1.fc17.i686

Version-Release number of selected component (if applicable):


How reproducible:
 yum -y update gnome-utils
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: ftp.jaist.ac.jp
 * rpmfusion-free-rawhide: fr2.rpmfind.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gnome-dictionary.i686 0:3.3.2-3.fc17 will be obsoleting
---> Package gnome-screenshot.i686 0:3.3.2-1.fc17 will be obsoleting
---> Package gnome-utils.i686 1:3.2.1-1.fc17 will be obsoleted
--> Processing Dependency: gnome-utils = 1:3.2.1-1.fc17 for package: 1:gnome-system-log-3.2.1-1.fc17.i686
---> Package gnome-utils-libs.i686 1:3.2.1-1.fc17 will be obsoleted
--> Finished Dependency Resolution
Error: Package: 1:gnome-system-log-3.2.1-1.fc17.i686 (@rawhide/17)
           Requires: gnome-utils = 1:3.2.1-1.fc17
           Removing: 1:gnome-utils-3.2.1-1.fc17.i686 (@rawhide/17)
               gnome-utils = 1:3.2.1-1.fc17
           Obsoleted By: gnome-screenshot-3.3.2-1.fc17.i686 (rawhide)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Belton 2012-03-06 02:22:46 EST
and same issue if you try to install gnome-system-log:

[root@tower20 ~]# yum install gnome-system-log
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gnome-system-log.x86_64 1:3.2.1-1.fc17 will be installed
--> Processing Dependency: gnome-utils = 1:3.2.1-1.fc17 for package: 1:gnome-system-log-3.2.1-1.fc17.x86_64
Package 1:gnome-utils-3.2.1-1.fc17.x86_64 is obsoleted by gnome-screenshot-3.3.2-1.fc17.x86_64 which is already installed
--> Finished Dependency Resolution
Error: Package: 1:gnome-system-log-3.2.1-1.fc17.x86_64 (fedora)
           Requires: gnome-utils = 1:3.2.1-1.fc17
           Available: 1:gnome-utils-3.2.1-1.fc17.x86_64 (fedora)
               gnome-utils = 1:3.2.1-1.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

(This bug should be changed to F17 instead of rawhide)
Comment 2 Daniel Belton 2012-03-14 00:28:42 EDT
now the obsoleting package has changed. Instead of gnome-screenshot obsoleting gnome-utils, it is gnome-search-tool

[root@tower20 ~]# yum install gnome-system-log
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gnome-system-log.x86_64 1:3.2.1-1.fc17 will be installed
--> Processing Dependency: gnome-utils = 1:3.2.1-1.fc17 for package: 1:gnome-system-log-3.2.1-1.fc17.x86_64
Package 1:gnome-utils-3.2.1-1.fc17.x86_64 is obsoleted by gnome-search-tool-3.3.1-4.fc17.x86_64 which is already installed
--> Finished Dependency Resolution
Error: Package: 1:gnome-system-log-3.2.1-1.fc17.x86_64 (fedora)
           Requires: gnome-utils = 1:3.2.1-1.fc17
           Available: 1:gnome-utils-3.2.1-1.fc17.x86_64 (fedora)
               gnome-utils = 1:3.2.1-1.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

But still can't install gnome-system-log.
Comment 3 Daniel Belton 2012-03-17 09:50:09 EDT
Ok, someone is on some really good drugs and isn't sharing with me! :lol:

This is getting even worse now.

Can someone please explain to me how a graphical disk usage application replaces a system log file viewer?

Setting up Install Process
Package gnome-system-log is obsoleted by baobab, trying to install baobab-3.3.3-2.fc17.x86_64 instead
Resolving Dependencies
--> Running transaction check
---> Package baobab.x86_64 0:3.3.3-2.fc17 will be installed
--> Finished Dependency Resolution

--------------

Available Packages
Name        : baobab
Arch        : x86_64
Version     : 3.3.3
Release     : 2.fc17
Size        : 352 k
Repo        : updates-testing
Summary     : A graphical directory tree analyzer
URL         : https://live.gnome.org/GnomeUtils/Baobab
License     : GPLv2+ and GFDL
Description : Baobab is able to scan either specific directories or the whole
            : filesystem, in order to give the user a graphical tree
            : representation including each directory size or percentage in the
            : branch.  It also auto-detects in real-time any change made to your
            : home folder as far as any mounted/unmounted device.


----------------

Available Packages
Name        : gnome-system-log
Arch        : x86_64
Epoch       : 1
Version     : 3.2.1
Release     : 1.fc17
Size        : 1.2 M
Repo        : fedora
Summary     : A log file viewer for the GNOME desktop
URL         : http://www.gnome.org
License     : GPLv2+
Description : The gnome-system-log package contains an application that lets you
            : view various system log files.
Comment 4 Daniel Belton 2012-03-19 02:31:14 EDT
I guess the dependencies are changing daily now.

[root@tower20 ~]# yum install gnome-system-log
Loaded plugins: etckeeper, langpacks, presto, refresh-packagekit, remove-with-
              : leaves, show-leaves
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gnome-system-log.x86_64 1:3.2.1-1.fc17 will be installed
--> Processing Dependency: gnome-utils = 1:3.2.1-1.fc17 for package: 1:gnome-system-log-3.2.1-1.fc17.x86_64
Package gnome-utils is obsoleted by baobab, but obsoleting package does not provide for requirements
--> Finished Dependency Resolution
Error: Package: 1:gnome-system-log-3.2.1-1.fc17.x86_64 (fedora)
           Requires: gnome-utils = 1:3.2.1-1.fc17
           Available: 1:gnome-utils-3.2.1-1.fc17.x86_64 (fedora)
               gnome-utils = 1:3.2.1-1.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 5 Adam Williamson 2012-03-19 17:17:04 EDT
https://admin.fedoraproject.org/updates/FEDORA-2012-4138 ought to fix this up, as I read it. This bug prevented the creation of desktop lives for TC2 and hence ought to block Beta.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2012-03-19 17:21:56 EDT
Amusingly, we don't really exactly have a criterion that says 'all release-blocking desktop live images must actually exist'. It's something I'm working on as a Deliverables SOP. But by implication, all the desktop-related criteria are broken by this, really.
Comment 7 Andre Robatino 2012-03-19 17:37:07 EDT
+1 Beta blocker per Adam's #fedora-qa request for votes.
Comment 8 Bruno Wolff III 2012-03-19 22:09:11 EDT
+1 Beta blocker
Comment 9 Daniel Belton 2012-03-19 22:44:56 EDT
The gnome-system-log-3.3.1-4.fc17 that AdamW linked to above does indeed install and doesn't have the gnome-utils dependencies, but, it can not read the log files.

When trying to open a log file (/var/log/messages) it never prompts for authorization, and the errors out because it doesn't have permission to access the file.
Comment 10 Daniel Belton 2012-03-19 22:46:18 EDT
Created attachment 571271 [details]
access to log file denied

error due to not asking for authorization to access the log file, then errors out because user doesn't have permissions to access file.
Comment 11 Kamil Páral 2012-03-20 08:43:16 EDT
+1 beta blocker. those gnome-system-log errors should probably be filed separately (and again proposed as a blocker).
Comment 12 Matthias Clasen 2012-03-20 08:56:55 EDT
The dependency / obsoletes problem is solved.
Please file a separate bug for functional problems with gnome-system-log
Comment 13 Jared Smith 2012-03-20 14:05:28 EDT
+1 beta blocker
Comment 14 Adam Williamson 2012-03-20 14:37:36 EDT
mclasen: yep, we know there's an update to fix it, but we need to have a blocker bug tracking the problem or else we wouldn't be able to push the update through the freeze.

Accepted as a blocker with the votes above.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Adam Williamson 2012-03-20 22:49:28 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Adam Williamson 2012-03-21 18:06:07 EDT
the update went stable, we can close this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Julian Sikorski 2012-03-21 19:17:11 EDT
I filed the root access problem as bug
Comment 18 Julian Sikorski 2012-03-21 19:17:40 EDT
I filed the root access problem as bug 805733.

Note You need to log in before you can comment on or make changes to this bug.