Bug 790337 - Result of `gluster peer status' is inconsistent
Result of `gluster peer status' is inconsistent
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All All
high Severity high
: ---
: ---
Assigned To: Vivek Agarwal
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-02-14 05:00 EST by Sachidananda Urs
Modified: 2016-02-17 19:02 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-02-14 05:00:04 EST
Description of problem:

When peer probe is done from different distributions of linux the peer status says `Rejected'/`Not connected' from different machines.

For example consider a FC11 and CentOS6 machines and do a peer probe on them to observe the above results.

Version-Release number of selected component (if applicable):

3.2.x and Mainline.

How reproducible:

Always.

Steps to Reproduce:
1. 5 servers (mixture of FC11 and CentOS6)
2. Peer probe from one of the machines and peer status from each one of them.
  
Actual results:

Peer Rejected / Not connected on peer status

Expected results:

Should show connected from all machines.

Additional info:

This is due to the sort versions on those machines. Statically compiling a version of sort and copying to all the machines solves the issue.

We should implement sort from within our FS than depending on distribution provided sort.
Comment 1 Anand Avati 2012-03-26 17:48:01 EDT
CHANGE: http://review.gluster.com/2990 (mgmt/glusterd: native sort of info files) merged in master by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.