Bug 79039 - select blocking evolution-mail
select blocking evolution-mail
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-04 16:54 EST by jmccann
Modified: 2015-01-14 18:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:34:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jmccann 2002-12-04 16:54:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021119

Description of problem:
Evolution 1.2 hangs when automatically reading mail from an imaps server after a
short time.  Please see <http://bugzilla.ximian.com/show_bug.cgi?id=34171> for
more information.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.killev
2. mv ~/evolution ~/backup
3. evolution
4. Configure evolution for imaps
5. Set mail check every 2 minutes
6. Check mail

Actual Results:  Evolution hangs

Expected Results:  Evolution retrieves mail.

Additional info:

I also downloaded the newer rawhide versions of the files listed in
<http://people.redhat.com/~katzj/evolution/RPMS/> from the rawhide ftp site. 
Unfortunately these had the same problem.

At the time of the hang strace of evolution-mail displays:
writev(26, [{"GIOP\1\0\1", 7}, {"\0\210\0\0\0", 5}, {"\0\0\0\0", 4},
{"<\360\377\277\1", 5}, {"\0\0\0", 3}, {"\30\0\0\0\0\0\0\0\366\353\264\177
\312*\353\10\0\0\0%O"..., 28}, {"\25\0\0\0operationProgressing\0", 25},
{"\0\0\0", 3}, {"\0\0\0\0", 4}, {"\24\0\0\0", 4}, {"2\0\0\0", 4}, {"Scanning
folders in \"IMAP server"..., 50},
{"\0\0", 2}, {"\0\0\200?", 4}], 14) = 148
select(27, [5 8 9 10 11 12 22 23 24 25 26], NULL, [5 8 9 10 11 12 22 23 24 25
26], NULL) = 1 (in [26])
read(26, "GIOP\1\0\1\1\f\0\0\0", 12)    = 12
read(26, "\0\0\0\0<\360\377\277\0\0\0\0", 12) = 12
gettimeofday({1039038157, 601084}, NULL) = 0
ioctl(3, 0x541b, [0])                   = 0
poll([{fd=3, events=POLLIN}, {fd=4, events=POLLIN|POLLPRI}, {fd=6,
events=POLLIN}, {fd=13, events=POLLIN, revents=POLLIN}, {fd=15, events=POLLIN},
{fd=17, events=POLLIN}, {fd=20, events=POLLIN}, {fd=5, events=POLLIN}, {fd=8,
events=POLLIN}, {fd=9, events=POLLIN}, {fd=10, events=POLLIN}, {fd=11,
events=POLLIN}, {fd=12, events=POLLIN}, {fd=22, events=POLLIN}, {fd=23,
events=POLLIN}, {fd=24, events=POLLIN}, {fd=25, events=POLLIN}, {fd=26,
events=POLLIN}], 18, 998) = 1
gettimeofday({1039038157, 601449}, NULL) = 0
read(13, "\0", 1)                       = 1
kill(25815, SIGRTMIN)                   = 0
gettimeofday({1039038157, 601866}, NULL) = 0
ioctl(3, 0x541b, [0])                   = 0
poll([{fd=3, events=POLLIN}, {fd=4, events=POLLIN|POLLPRI}, {fd=6,
events=POLLIN}, {fd=13, events=POLLIN}, {fd=15, events=POLLIN}, {fd=17,
events=POLLIN}, {fd=20, events=POLLIN}], 7, 0) = 0
writev(25, [{"GIOP\1\0\1", 7}, {"\0X\0\0\0", 5}, {"\0\0\0\0", 4},
{"\254\360\377\277\1", 5}, {"\0\0\0", 3},
{"\30\0\0\0\0\0\0\0\226\276\235\234o\357\234^\f\0\0\0\236"..., 28},
{"\24\0\0\0notifyFolderUpdated\0", 24}, {"\0\0\0\0", 4}, {"\f\0\0\0", 4},
{"/Mail/megan\0", 12}, {"\0\0\0\0", 4}], 11) = 100
select(27, [5 8 9 10 11 12 22 23 24 25 26], NULL, [5 8 9 10 11 12 22 23 24 25
26], NULL

The debug output produced by setting CAMEL_VERBOSE_DEBUG=1 didn't show anything
unusual.
Comment 1 jmccann 2002-12-04 16:57:26 EST
This seems to be similar to bug 75822.
Comment 2 Jeremy Katz 2002-12-04 17:01:00 EST
If you look at your ps output, is evolution-executive-summary in state T (stopped)?
Comment 3 jmccann 2002-12-04 17:18:05 EST
I had to wait for it to happen again.  Yes, evolution-executive-summary is stopped.

%  ps -ealf | grep evol
000 S mccannwj 27626     1  0  75   0    -  5776 schedu 17:05 ?        00:00:01
evolution
000 S mccannwj 27661     1  0  75   0    -  5876 schedu 17:05 ?        00:00:00
evolution-addressbook --oaf-activate-iid=OAFIID:GNOME_Evolution_Addressbook_Shel
000 S mccannwj 27668     1  0  75   0    -  5973 schedu 17:05 ?        00:00:00
evolution-calendar --oaf-activate-iid=OAFIID:GNOME_Evolution_Calendar_ShellCompo
000 S mccannwj 27686     1  0  75   0    -  5162 schedu 17:05 ?        00:00:00
evolution-alarm-notify --oaf-activate-iid=OAFIID:GNOME_Evolution_Calendar_AlarmN
000 S mccannwj 27649     1  0  75   0    - 14631 schedu 17:05 ?        00:00:00
evolution-mail --oaf-activate-iid=OAFIID:GNOME_Evolution_Mail_ShellComponent --o
000 T mccannwj 27683     1  0  75   0    -  5688 do_sig 17:05 ?        00:00:00
evolution-executive-summary --oaf-activate-iid=OAFIID:GNOME_Evolution_Summary_Sh
000 S mccannwj 28620 28008  0  76   0    -   879 pipe_w 17:16 pts/1    00:00:00
grep evol
Comment 4 jmccann 2002-12-04 17:28:52 EST
I should also mention that I emailed the evolution-hackers list:
<http://lists.ximian.com/archives/public/evolution-hackers/2002-December/005316.html>
Comment 5 jmccann 2002-12-10 10:38:06 EST
On the recommendation of the evolution-hackers list I made sure that the soup
package was current.  I updated from the rawhide version (soup-0.7.4-3) to the
ximian version (soup-0.7.9-1).  Since doing so evolution has been running fine
(12 hours or so).  Is it possible to update soup in rawhide?  I would prefer to
use only redhat packages.
Comment 6 Jeremy Katz 2002-12-10 11:22:08 EST
Yes, I saw the discussion there and am working on getting an updated package
into rawhide.  It is minorly complicated by the fact that the newest tarball on
ftp.gnome.org is 0.7.4, which is why it was in rawhide :(
Comment 7 jmccann 2002-12-10 11:34:25 EST
Well here is the ximian source RPM anyway
ftp://ftp.ximian.com/pub/ximian-evolution/redhat-80-i386/source/soup-0.7.9-1.ximian.1.src.rpm
Comment 8 Jeremy Katz 2002-12-13 11:05:16 EST
soup-0.7.9-4 should be available in rawhide now and seems to fix this for me
Comment 9 Bill Nottingham 2006-08-04 16:34:25 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.