Bug 790460 - Ortho file not present for Bodo (brx_In) locale
Summary: Ortho file not present for Bodo (brx_In) locale
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-14 15:24 UTC by Pravin Satpute
Modified: 2012-04-12 02:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-21 11:07:41 UTC
Type: ---


Attachments (Terms of Use)
brx ortho file submitted by Parag in upstream bugzilla (5.16 KB, patch)
2012-02-14 15:24 UTC, Pravin Satpute
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 25651 None None None Never

Description Pravin Satpute 2012-02-14 15:24:11 UTC
Created attachment 561944 [details]
brx ortho file submitted by Parag in upstream bugzilla

Description of problem:
Bodo language is an Indian Language recognized by Govt. of India and its spoken
nearly 2 million people. This language uses Devanagari code as written script.

Since orthographic file is not available for this langauge, fc-match not selecting correct font for this language.

Version-Release number of selected component (if applicable):
fontconfig-2.8.0-4.fc16.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. $fc-match :lang=brx
2.
3.
  
Actual results:
Returning DejaVuSans.ttf: "DejaVu Sans" "Book"

Expected results:
Should return Lohit Devanagari

Additional info:
Locale for Bodo now available glibc.

This is part of Fedora 17 feature
https://fedoraproject.org/wiki/Features/Additional_Indic_Langs  and blocks the feature.

Comment 1 Pravin Satpute 2012-03-13 05:42:23 UTC
upstream fontconfig 2.9.0 release is available with this fix http://lists.freedesktop.org/archives/fontconfig/2012-March/003811.html

Comment 2 Akira TAGOH 2012-03-21 11:07:41 UTC
Fixed in fontconfig-2.9.0-1.fc18.

Comment 3 Fedora Update System 2012-03-23 06:58:00 UTC
fontconfig-2.8.0-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fontconfig-2.8.0-6.fc17

Comment 4 Fedora Update System 2012-04-12 02:16:07 UTC
fontconfig-2.8.0-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.