Bug 790471 - Need update in ks.orth file
Summary: Need update in ks.orth file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-14 15:52 UTC by Pravin Satpute
Modified: 2012-04-12 02:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-21 11:06:57 UTC
Type: ---


Attachments (Terms of Use)
It add the newly added characters in Unicode for Kashmiri language (585 bytes, patch)
2012-02-14 15:54 UTC, Pravin Satpute
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 27195 None None None Never

Description Pravin Satpute 2012-02-14 15:52:26 UTC
Description of problem:
Ref. http://www.unicode.org/charts/PDF/U0600.pdf

On third page, it is listed in annotation which characters suppose to use for kashmiri

so they need to be added in ks.orth file for understanding which font actually support kashmiri in Arabic script

Version-Release number of selected component (if applicable):
fontconfig-2.8.0-4

How reproducible:
everytime

Steps to Reproduce:
1. $fc-match :lang=ks 
2. DroidSansArabic.ttf: "Droid Sans" "Regular"
3. 
  
Actual results:
Returns DroidSansArabic.ttf

Expected results:
It should not return DroidSansArabic.ttf, since it does not contains required characters.

Additional info:
This is part of Fedora 17 feature
https://fedoraproject.org/wiki/Features/Additional_Indic_Langs

Comment 1 Pravin Satpute 2012-02-14 15:54:25 UTC
Created attachment 561951 [details]
It add the newly added characters in Unicode for Kashmiri language

Comment 2 Pravin Satpute 2012-03-13 05:42:57 UTC
upstream fontconfig 2.9.0 release is available with this fix http://lists.freedesktop.org/archives/fontconfig/2012-March/003811.html

Comment 3 Akira TAGOH 2012-03-21 11:06:57 UTC
Fixed in fontconfig-2.9.0-1.fc18

Comment 4 Fedora Update System 2012-03-23 06:57:54 UTC
fontconfig-2.8.0-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fontconfig-2.8.0-6.fc17

Comment 5 Fedora Update System 2012-04-12 02:16:00 UTC
fontconfig-2.8.0-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.