This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 790537 - [abrt] kernel: WARNING: at arch/x86/kernel/traps.c:729 do_device_not_available+0x33/0x40()
[abrt] kernel: WARNING: at arch/x86/kernel/traps.c:729 do_device_not_availabl...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:c290535f3a897ac782190b3a5aa...
:
Depends On:
Blocks: F17Alpha-accepted/F17AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-02-14 14:24 EST by Nicolas Mailhot
Modified: 2012-02-20 21:22 EST (History)
18 users (show)

See Also:
Fixed In Version: kernel-3.3.0-0.rc3.git7.2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-20 21:22:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2012-02-14 14:24:25 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-0.rc3.git5.1.fc17.x86_64 root=/dev/VolGroup00/systeme ro SYSFONT=latarcyrheb-sun16 LANG=fr_FR.UTF-8 KEYTABLE=fr-latin9 rd.info
comment:        On boot
kernel:         3.3.0-0.rc3.git5.1.fc17.x86_64
reason:         WARNING: at arch/x86/kernel/traps.c:729 do_device_not_available+0x33/0x40()
time:           mar. 14 févr. 2012 20:12:10 CET

backtrace:
:WARNING: at arch/x86/kernel/traps.c:729 do_device_not_available+0x33/0x40()
:Hardware name: EP45-DS5
:Modules linked in: it87 hwmon_vid coretemp tuner_simple tuner_types wm8775 tda9887 tda8290 tuner cx25840 snd_hda_codec_hdmi microcode ivtv cx2341x tveeprom v4l2_common pcspkr serio_raw snd_emu10k1 videodev snd_util_mem v4l2_compat_ioctl32 snd_ac97_codec snd_hda_codec_realtek ac97_bus media snd_rawmidi snd_seq_device i2c_i801 iTCO_wdt snd_hda_intel iTCO_vendor_support snd_hda_codec snd_hwdep snd_pcm r8169 mii snd_page_alloc snd_timer snd soundcore uinput raid1 ata_generic pata_acpi firewire_ohci firewire_core crc_itu_t pata_jmicron radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 941, comm: postfix-script Not tainted 3.3.0-0.rc3.git5.1.fc17.x86_64 #1
:Call Trace:
: [<ffffffff81060c1f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8132b96d>] ? trace_hardirqs_off_thunk+0x3a/0x3c
: [<ffffffff81060c7a>] warn_slowpath_null+0x1a/0x20
: [<ffffffff8169f193>] do_device_not_available+0x33/0x40
: [<ffffffff816a7f0b>] device_not_available+0x1b/0x20
: [<ffffffff81024937>] ? save_i387_xstate+0xb7/0x240
: [<ffffffff81024923>] ? save_i387_xstate+0xa3/0x240
: [<ffffffff810196a2>] do_signal+0x5d2/0x7c0
: [<ffffffff810cd7dd>] ? trace_hardirqs_on+0xd/0x10
: [<ffffffff8169df00>] ? _raw_spin_unlock_irq+0x30/0x50
: [<ffffffff81019940>] do_notify_resume+0x90/0xc0
: [<ffffffff816a6f62>] int_signal+0x12/0x17

smolt_data:
:
:
:Général
:=================================
:UUID: b78fe0ae-e51d-40f8-8e68-7f2478f9cf2a
:SE: Fedora release 18 (Rawhide)
:Niveau d'exécution par défaut: 5
:Langue: fr_FR.UTF-8
:Plateforme: x86_64
:BogoMIPS: 6332.33
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM)2 Duo CPU     E8500  @ 3.16GHz
:Stepping du processeur: 10
:Famille de processeur: 6
:Modèle du processeur: 23
:Nombre de processeurs: 2
:Vitesse du processeur: 2834
:Mémoire du système: 3934
:Swap du système: 4094
:Fabricant: Gigabyte Technology Co., Ltd.
:Système: EP45-DS5 
:Type d'ordinateur: Desktop
:Noyau: 3.3.0-0.rc3.git5.1.fc17.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(32902:11808:5208:20480) pci, None, HOST/PCI, GA-EP45-DS5 Motherboard
:(32902:11809:5208:20480) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(32902:14896:5208:20481) pci, i801_smbus, SERIAL, GA-EP45-DS5 Motherboard
:(32902:14882:5208:45061) pci, ahci, STORAGE, GA-EP45-DS5 Motherboard
:(32902:14870:5208:20481) pci, None, PCI/ISA, GA-EP45-DS5 Motherboard
:(32902:9294:5208:20480) pci, None, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14901:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14900:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14905:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14902:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14906:5208:20486) pci, ehci_hcd, USB, GA-EP45-DS5 Motherboard
:(32902:14908:5208:20486) pci, ehci_hcd, USB, GA-EP45-DS5 Motherboard
:(6523:9059:5208:45056) pci, pata_jmicron, STORAGE, GA-EP45-DS5 Motherboard
:(6523:9059:5208:45056) pci, ahci, STORAGE, GA-EP45-DS5 Motherboard
:(32902:14918:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14912:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14920:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:14910:5208:41218) pci, snd_hda_intel, MULTIMEDIA, GA-EP45-DS5 Motherboard
:(4354:4:4354:16385) pci, snd_emu10k1, MULTIMEDIA_AUDIO, E-MU 1010
:(32902:14903:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(4354:16385:4354:16) pci, firewire_ohci, FIREWIRE, SB Audigy FireWire Port
:(17476:22:112:32771) pci, ivtv, MULTIMEDIA_VIDEO, WinTV PVR 150
:(32902:14904:5208:20484) pci, uhci_hcd, USB, GA-EP45-DS5 Motherboard
:(4098:43672:5963:43672) pci, snd_hda_intel, MULTIMEDIA, Sapphire HD 6450 1GB DDR3
:(4098:26489:5963:57700) pci, radeon, VIDEO, Sapphire HD 6450 1GB DDR3
:(32902:14922:5208:20481) pci, pcieport, PCI/PCI, GA-EP45-DS5 Motherboard
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup00-systeme / ext4 4096 4096 12496068 7458303 6829209 3145728 2663602 2663602
:/dev/md0 /boot ext4 4096 4096 522607 486410 460230 131072 130837 130837
:/dev/mapper/VolGroup00-utilisateur /home ext4 4096 4096 25127330 4945053 3686763 6291456 6172670 6172670
:
Comment 1 Mikko Tiihonen 2012-02-16 02:36:57 EST
During normal boot (not resume)

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 DiEOrLivE 2012-02-16 09:32:35 EST
boot from LiveCD

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Dave Jones 2012-02-16 15:30:46 EST
Linus just removed this WARN_ON, and rewrote a huge chunk of the i387 code in 15d8791cae75dca27bfda8ecfe87dca9379d6bb0
Comment 4 John Dulaney 2012-02-16 17:08:55 EST
Running F17 Alpha RC2 in a qemu/kvm VM under F16

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Adam Williamson 2012-02-16 19:18:28 EST
Proposing as NTH, per kernel team request - we'll kick this around tomorrow. It is entirely cosmetic, but kernel team say just about everyone will hit and report it if we don't take a fix.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2012-02-17 12:37:20 EST
Discussed at 2012-02-17 NTH review meeting. Accepted as NTH as we consider it worthwhile to prevent the kernel team being overwhelmed with reports. Note that this should not be read as a general precedent for accepting significant rewrites of sensitive code in the kernel post-freeze - we're doing it this time because we have enough spare time before release to deal with any problems, and we're reasonably confident the rewritten code will work, but we might certainly choose to reject a similarly big-hammer-for-small-nut NTH/blocker proposal in future.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Frank Murphy 2012-02-17 15:00:27 EST
Was doing joining *.rpmnew with ny own. Abrt popped up the old kernel problem.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Fedora Update System 2012-02-17 15:13:14 EST
kernel-3.3.0-0.rc3.git7.2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.0-0.rc3.git7.2.fc17
Comment 9 Fedora Update System 2012-02-17 21:25:09 EST
Package kernel-3.3.0-0.rc3.git7.2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.0-0.rc3.git7.2.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1948/kernel-3.3.0-0.rc3.git7.2.fc17
then log in and leave karma (feedback).
Comment 10 Hedayat Vatankhah 2012-02-18 09:39:56 EST
I simply booted Fedora 17 RC2 for the first time and saw this crash!

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 11 Clyde E. Kunkel 2012-02-18 11:52:36 EST
Reading mail in thunderbird.  Did notice that when Gnome 3 desktop first came up, apps were frozen and couldn't get any responses tho mouse moved.  Viewing top in tty-3 showed very high (>20%) cpu for X.  Back to shell and c-a-bs to relogon.  Got this waring subsequently.

Package: kernel
OS Release: Fedora release 18 (Rawhide)
Comment 12 Barry Godusky 2012-02-20 15:12:54 EST
Just booting the system caused this error

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 13 Fedora Update System 2012-02-20 21:22:25 EST
kernel-3.3.0-0.rc3.git7.2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.