Bug 790690 - quota should be using portreserve
quota should be using portreserve
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: quota (Show other bugs)
6.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Petr Pisar
qe-baseos-daemons
:
Depends On:
Blocks: 103401
  Show dependency treegraph
 
Reported: 2012-02-15 03:07 EST by Karel Srot
Modified: 2012-02-23 08:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-23 08:32:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2012-02-15 03:07:37 EST
To avoid port conflicts with services such as CUPS or IMAP 
quota
should be using portreserve for reserving respective ports
within range 600 - 1023. According to /etc/services quota
might be using port(s) withing this range.


Typical changes required:

Given a SysV service package that uses a particular port, (say, krb5_prop/tcp -
754):

1) Create a file named after the service, for example 'krb5_prop', which
contains:

krb5_prop/tcp

2) In the spec, install this file in /etc/portreserve, i.e.,
/etc/portreserve/krb5_prop

3) In the spec, add 'Requires: portreserve' to the package that provides the
server.

4) In the init script, in the start() stanza, add:

    [ -x /sbin/portrelease ] && /sbin/portrelease krb5_prop &>/dev/null || :

before starting the daemon.


Some background can be found in bug 103401.
Comment 1 Petr Pisar 2012-02-23 04:55:49 EST
quota_nld executable is an RPC service. I think the portreserve hack is intended for non-RPC services. So I think this request is not applicable to quota package.
Comment 2 Ondrej Vasik 2012-02-23 06:55:03 EST
You are right that portreserve hack is intended for non-RPC services - as RPC services usually use dynamic (and random between 600-1023) port. This is the default case even for quota_nld, so if you think that using portreserve for port 875 is not a good idea, feel free to close this report. I'm not really sure, how this will work for service opened via portmap, even if this will be on static port in reserved area.
Comment 3 Petr Pisar 2012-02-23 08:32:36 EST
Yes, default quota_nld configuration is to select random port through rpcbind. So adding portreserve has no sense.

Note You need to log in before you can comment on or make changes to this bug.