This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 790979 - Memory leaks and crashers found in python bindings in rpm-4.9.1.2-12.fc17 using gcc-with-cpychecker static analyzer
Memory leaks and crashers found in python bindings in rpm-4.9.1.2-12.fc17 usi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
http://fedorapeople.org/~dmalcolm/gcc...
:
Depends On:
Blocks: cpychecker
  Show dependency treegraph
 
Reported: 2012-02-15 16:02 EST by Dave Malcolm
Modified: 2012-05-08 08:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 08:10:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2012-02-15 16:02:07 EST
Description of problem:
I've been writing an experimental static analysis tool to detect bugs commonly occurring within C Python extension modules:
  https://fedorahosted.org/gcc-python-plugin/
  http://gcc-python-plugin.readthedocs.org/en/latest/cpychecker.html
  http://fedoraproject.org/wiki/Features/StaticAnalysisOfPythonRefcounts

I ran the latest version of the tool (in git master; post 0.9) on
rpm-4.9.1.2-12.fc17.src.rpm, and it reports various errors.

You can see a list of errors here, triaged into categories (from most significant to least significant):
http://fedorapeople.org/~dmalcolm/gcc-python-plugin/2012-02-15/rpm-4.9.1.2-12.fc17/

Although the two bugs in the final category ("Returning (PyObject*)NULL without setting an exception") are false positives, I believe that all of the other bugs reported there are true errors.

There may of course be other bugs in my checker tool.

I submitted patches for these problems to rpm-maint in December 2011; see:
 http://lists.rpm.org/pipermail/rpm-maint/2011-December/003138.html
 http://lists.rpm.org/pipermail/rpm-maint/2011-December/003139.html
 http://lists.rpm.org/pipermail/rpm-maint/2011-December/003145.html
 http://lists.rpm.org/pipermail/rpm-maint/2011-December/003152.html
 http://lists.rpm.org/pipermail/rpm-maint/2011-December/003153.html
but I'm filing this here to ensure that the fixes make it into Fedora (and eventually RHEL).

Hope this is helpful; let me know if you need help reading the logs that the tool generates - I know that it could use some improvement.

Version-Release number of selected component (if applicable):
rpm-4.9.1.2-12.fc17
gcc-python-plugin post-0.9 git 073d390de53ef52136bd90e5ac06f1ef833d047d running the checker in an *f16* chroot
Comment 1 Fedora Admin XMLRPC Client 2012-04-13 19:07:55 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2012-04-13 19:11:16 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Panu Matilainen 2012-05-08 08:10:05 EDT
The entire patch set is part of rpm >= 4.10, in rawhide since late March, and the worser memleaks got backported to rpm 4.9.x in older Fedoras as well.

Note You need to log in before you can comment on or make changes to this bug.