Bug 791045 - FTBFS with OpenJDK7
FTBFS with OpenJDK7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: velocity (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-15 20:07 EST by Omair Majid
Modified: 2012-02-17 14:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-17 14:21:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to add compatibility with jdbc 4.1 (1.61 KB, patch)
2012-02-15 20:08 EST, Omair Majid
no flags Details | Diff

  None (edit)
Description Omair Majid 2012-02-15 20:07:22 EST
Velocity fails to build from source with OpenJDK7. This is caused by a change in the JDBC 4.1 API. The attached patch fixes that.

Please see https://fedoraproject.org/wiki/Java7_Package_Rebuild_Status for more information.
Comment 1 Omair Majid 2012-02-15 20:08:43 EST
Created attachment 562365 [details]
patch to add compatibility with jdbc 4.1
Comment 2 Deepak Bhole 2012-02-17 14:21:04 EST
Pushed. Thanks Omair.

Note You need to log in before you can comment on or make changes to this bug.