Bug 79114 - modprobe usb-uhci hangs at boot
modprobe usb-uhci hangs at boot
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-05 16:22 EST by Pontus Enhager
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-26 15:24:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from lspci -vvv (7.27 KB, text/plain)
2002-12-05 16:23 EST, Pontus Enhager
no flags Details

  None (edit)
Description Pontus Enhager 2002-12-05 16:22:17 EST
Description of Problem:
When booting the computer hangs at 4/5 occasions when reaching the point where
usb-uhci is initialised

Version-Release number of selected component (if applicable):
redhat 8.0
kernel 2.4.18-18-8 and 2.4.18-14
computer have to be turned off (button) as the keyboard is not initialised
yet(my guess)
How Reproducible:
4 out of 5 reboots

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
if adding the -xv suffix to rc.sysinit, the following lines are the two last

Initializing USB controller (usb-uhci): +shift
+ initlog -q -c 'modprobe usb-uhci'

Expected Results:
Normal boot

Additional Information:
Computer:IBM Netvista A30p
Intel p4
i845g motherboard
usb keyboard and mouse
Comment 1 Pontus Enhager 2002-12-05 16:23:10 EST
Created attachment 87604 [details]
output from lspci -vvv
Comment 2 Pontus Enhager 2002-12-05 16:38:04 EST
the correct model no of the computer is Netvista 8310-KRG as i just learned
Comment 3 Pontus Enhager 2002-12-19 02:24:59 EST
I have managed to get the rawhide kernel-2.4.20-0.pp.11.src.rpm to compile and
boot on my computer and it seems to fix the hang (after approx 7 reboots) did
anything related go into that kernel ? will return with more feedback!
Comment 4 Pete Zaitcev 2002-12-19 04:12:52 EST
I did not do anything specific, the usb-uhci we take completely from upstream.
Did _any_ sort of Red Hat kernel work on the box before, and if yes, what
was the version?
Comment 5 Pontus Enhager 2002-12-19 05:03:40 EST
No previous redhat kernel have worked before (tested 2.4.18-[14,18.8]) this one
appears to work :-)
Comment 6 Pontus Enhager 2002-12-21 09:07:55 EST
i have also tried pp-9 which did not boot at all so i cannot really tell...
Comment 7 Pontus Enhager 2002-12-26 15:24:55 EST
Works also on 2.4.20-2.2 - i change resolution to RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.