Bug 791159 - mdadm write intent map not functioning as before
mdadm write intent map not functioning as before
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jes Sorensen
Fedora Extras Quality Assurance
:
Depends On: 769323 807743
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-16 06:22 EST by Jes Sorensen
Modified: 2012-06-06 22:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: mdadm-3.2.3-7.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 769323
Environment:
Last Closed: 2012-04-25 23:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2012-02-16 06:22:00 EST
+++ This bug was initially created as a clone of Bug #769323 +++

Description of problem:

When a temporarily missing RAID 1 component becomes available, an incremental assembly should consult the write intent map and resynchronize the device with those blocks recorded as changed.  Instead, "mdadm -I --run /dev/sdc1" declares the temporarily missing component "invalid".

Version-Release number of selected component (if applicable):

mdadm-3.2.2-125.fc16.x86_64
kernel-3.1.5-6.fc16.x86_64

How reproducible:

Always.

Steps to Reproduce:
1.  Create a RAID 1 device as so:

mdadm --create /dev/md0 --level=1 --raid-devices=2 /dev/sdb1 --write-mostly /dev/sdc1 --bitmap=/var/preserve/vg_extern0 --assume-clean

3. Record the result of "mdadm -D --brief /dev/md0" in /etc/mdadm.conf:

ARRAY /dev/md0 metadata=1.2 bitmap=/var/preserve/extern0 name=myhost:md0 UUID=c84d260e:f10d4241:af5e0c24:1f18d143

2. Use the RAID device (i.e., create a logical volume group containing it, put a file system on one of the logical volumes).  This works as expected.

3. Shut down the system.

4. Physically disconnect the /dev/sdc device.  Leave /dev/sdb connected.

5. Boot the system.  /dev/md0 will be assembled and run with the one available component.

6. Use the RAID 1 device.  Activate the logical volume, mount the filesystem from it, and write a file in that file system.

7. Shut down the system.

8. Physically reattach the /dev/sdc device.

9. Boot the system.

10. /dev/md0 will be created with only the /dev/sdb component participating.

11.  sudo mdadm -I --run /dev/sdc1 
  
Actual results:

mdadm: failed to add /dev/sdc1 to /dev/md0: Invalid argument.

Expected results:

/dev/sdc1 to participate in the RAID 1 array, and shown to by synchronizing in results of "cat /proc/mdstat".  If the writes made to the one RAID component were small, the synchronization will be finished before you can observe the synchronization state, and the RAID device will contain both components up to date "[UU]".

Additional info:

This worked as expected in Fedora 14.

--- Additional comment from Jes.Sorensen@redhat.com on 2012-01-03 05:33:13 EST ---

Stephen,

What is the output from mdadm when you try to add the second device?
It has to be more than just 'Invalid argument'

Second, you shouldn't need to add --run when specifying -I, I don't know
if that makes any difference.

Jes

--- Additional comment from Jes.Sorensen@redhat.com on 2012-01-03 08:15:21 EST ---

Stephen,

Ok, I tried reproducing the bug here, and it looks like I am seeing the
exact same as you.

I will try and investigate further.

Jes

--- Additional comment from Jes.Sorensen@redhat.com on 2012-01-03 10:33:45 EST ---

Ok, this is strange.

If I try to add the drive this way:

mdadm -I --run /dev/sdf3

I get the same error as you. On the other hand if I do the following, it
works just fine:

mdadm -a /dev/md42 /dev/sdf3

Looks like something isn't detected correctly by either the kernel or mdadm
when doing an Incremental add. This happens with the latest mdadm from
Neil's git tree and Linus' top of tree kernel as well btw.

Jes

--- Additional comment from sschaefer@acm.org on 2012-01-04 16:35:50 EST ---

Thanks for pursuing this and sorry for not responding; I'd been under the weather.  I'll see if the "-a" version does what I need - if the write intent map gets ignored, I end up with a 16 hour sync that needs to finish in a 10 hour window.

--- Additional comment from Jes.Sorensen@redhat.com on 2012-01-05 03:43:09 EST ---

Stephen,

No worries, I've been battling being under the weather myself. I think
you have a genuine bug here, but -a seems to work as a workaround for me.
I think it respects the bitmap, but I would certainly appreciate it if you
can confirm that it does.

I will continue investigating why -I doesn't do the right thing.

Cheers,
Jes

--- Additional comment from sschaefer@acm.org on 2012-01-05 11:49:28 EST ---

I'm pleased to report that, with the -a workaround, the write intent map works as hoped.  Thanks,

    - Stephen

--- Additional comment from Jes.Sorensen@redhat.com on 2012-01-06 01:32:24 EST ---

Stephen,

Thanks for confirming this. This means at least the core infrastructure
seems to be working as expected. I'll look into why it doesn't do the
right thing with -I

Cheers,
Jes
Comment 1 Fedora Update System 2012-03-28 11:51:56 EDT
mdadm-3.2.3-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.2.3-7.fc15
Comment 2 Fedora Update System 2012-03-30 22:58:10 EDT
Package mdadm-3.2.3-7.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mdadm-3.2.3-7.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4959/mdadm-3.2.3-7.fc15
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-04-25 23:24:38 EDT
mdadm-3.2.3-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2012-05-02 06:20:07 EDT
mdadm-3.2.3-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.2.3-9.fc15
Comment 5 Fedora Update System 2012-05-10 10:54:59 EDT
mdadm-3.2.4-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.2.4-2.fc15
Comment 6 Fedora Update System 2012-05-15 12:48:15 EDT
mdadm-3.2.4-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.2.4-3.fc15
Comment 7 Fedora Update System 2012-05-21 11:21:23 EDT
mdadm-3.2.5-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-1.fc15
Comment 8 Fedora Update System 2012-06-06 22:49:58 EDT
mdadm-3.2.5-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.