Bug 791339 - FTBFS with OpenJDK7
FTBFS with OpenJDK7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plexus-containers (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fernando Nasser
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-16 14:39 EST by Omair Majid
Modified: 2012-02-17 13:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-17 13:37:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix build with openjdk7 (1.54 KB, text/x-csrc)
2012-02-16 14:39 EST, Omair Majid
no flags Details

  None (edit)
Description Omair Majid 2012-02-16 14:39:34 EST
Created attachment 562575 [details]
fix build with openjdk7

plexus-containers fails to build from source with OpenJDK7. This is caused because ${java.home}/../lib/tools.jar is not being added to the build classpath - the vendor (in OpenJDK7) is "Oracle Corporation", not "Sun Microsystems, Inc". To keep this package compatible with both OpenJDK6 and OpenJDK7, tools.jar should always be added to the classpath.

Please see https://fedoraproject.org/wiki/Java7_Package_Rebuild_Status for more information.
Comment 1 Deepak Bhole 2012-02-17 13:37:28 EST
Pushed. Thanks Omair!

Note You need to log in before you can comment on or make changes to this bug.