Bug 791344 - /usr/share/qemu/sgabios.bin link missing
/usr/share/qemu/sgabios.bin link missing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-16 14:54 EST by Dave Allan
Modified: 2016-04-26 10:35 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-11 16:23:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Allan 2012-02-16 14:54:25 EST
Description of problem:
I configured a VM to use sgabios but got no output on my serial console:

# qemu-kvm -nographic
Could not open option rom 'sgabios.bin': No such file or directory

Manually creating the symlink in /usr/share/qemu fixes things:

# ln -s /usr/share/sgabios/sgabios.bin /usr/share/qemu

Version-Release number of selected component (if applicable):
sgabios-0-0.20110621SVN.fc16.x86_64

How reproducible:
100%
Comment 1 Fedora Admin XMLRPC Client 2012-04-17 14:34:58 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Cole Robinson 2012-05-29 10:03:39 EDT
This is actually a qemu packaging bug, qemu needs to depend on sgabios, and create that symlink like it does for other bioses. Affects f16+
Comment 3 Cole Robinson 2012-07-10 07:27:02 EDT
Moving to POST since it's just a spec tweak
Comment 4 Cole Robinson 2012-08-03 07:22:49 EDT
qemu-0.15.1-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-11305/qemu-0.15.1-7.fc16
Comment 5 Cole Robinson 2012-08-11 16:23:24 EDT
Fixed in qemu-0.15.1-7.fc16

Note You need to log in before you can comment on or make changes to this bug.