Bug 791347 - Cannot install icewm because of broken dependencies
Summary: Cannot install icewm because of broken dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: icewm
Version: el6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gilboa Davara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-16 20:00 UTC by Bob McClure
Modified: 2012-03-24 19:10 UTC (History)
2 users (show)

Fixed In Version: icewm-1.3.7-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-20 00:20:21 UTC


Attachments (Terms of Use)

Description Bob McClure 2012-02-16 20:00:43 UTC
Description of problem: icewm requires bluecurve-icon-theme.  bluecurve-icon-theme requires bluecurve-cursor-theme.  bluecurve-cursor-theme will not install because "Cannot install package bluecurve-cursor-theme-8.0.2-6.el6.noarch. It is obsoleted by installed package dmz-cursor-themes-0.4-4.el6.noarch".


Version-Release number of selected component (if applicable): icewm.x86_64 0:1.3.7-1.el6


How reproducible: Always


Steps to Reproduce:
1.yum install icewm

2.yum install http://dl.fedoraproject.org/pub/epel/6/x86_64/bluecurve-cursor-theme-8.0.2-6.el6.noarch.rpm
3.
  
Actual results:
For step 1: Resolving Dependencies
--> Running transaction check
---> Package icewm.x86_64 0:1.3.7-1.el6 will be installed
--> Processing Dependency: bluecurve-icon-theme for package: icewm-1.3.7-1.el6.x86_64
--> Running transaction check
---> Package bluecurve-icon-theme.noarch 0:8.0.2-6.el6 will be installed
--> Processing Dependency: bluecurve-cursor-theme for package: bluecurve-icon-theme-8.0.2-6.el6.noarch
--> Finished Dependency Resolution
Error: Package: bluecurve-icon-theme-8.0.2-6.el6.noarch (epel)
           Requires: bluecurve-cursor-theme
           Available: bluecurve-cursor-theme-8.0.2-6.el6.noarch (epel)
               bluecurve-cursor-theme = 8.0.2-6.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

For step 2: Examining /var/tmp/yum-root-w2z3Sl/bluecurve-cursor-theme-8.0.2-6.el6.noarch.rpm: bluecurve-cursor-theme-8.0.2-6.el6.noarch
Cannot install package bluecurve-cursor-theme-8.0.2-6.el6.noarch. It is obsoleted by installed package dmz-cursor-themes-0.4-4.el6.noarch
Error: Nothing to do


Expected results: Installation of icewm and dependencies.


Additional info:

Comment 1 Gilboa Davara 2012-02-20 00:09:52 UTC
I plan to issue a fixed build next week.
Assigning the bug to me.

Comment 2 Gilboa Davara 2012-02-20 00:20:21 UTC

*** This bug has been marked as a duplicate of bug 768844 ***

Comment 3 Fedora Update System 2012-03-05 06:07:53 UTC
icewm-1.3.7-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/icewm-1.3.7-3.el6

Comment 4 Fedora Update System 2012-03-24 19:10:01 UTC
icewm-1.3.7-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.