Bug 79152 - wizard to download additional multimedia support
wizard to download additional multimedia support
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-06 09:18 EST by Marco Baldi
Modified: 2014-03-16 22:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-09 10:56:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Baldi 2002-12-06 09:18:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
rh8 comes without mp3, dvd, divx support, because of licensing issues.
it's possible to download the needed programs, however many users try rh8, but 
then switch to other distro (usually mandrake). probably they don't know where 
to download mp3 players, or they just don't understand why there isn't an mp3 
or divx player in the three cds of the rh8 setup (users really don't care about 
mp3 licensing issues).
while i agree with redhat about potential licensing issues i think you should 
find a solution to this problem.
here's what i suggest:
after the setup is about to finish, on one of the last steps, you offer the 
user to download additional multimedia players from a redhat site. you clearly 
state that the programs are "unsupported", and warn the user about licensing 
issues, and explain why redhat hasn't included these programs in the setup cds. 
this way you avoid legal problems because the multimedia players aren't 
included in the distro, and at the same time you give the users the option to 
easily install these programs. please remember that newbies may know where to 
download an mp3 player for windows, but usually don't know where to find one 
for linux. this way you let the users know that such programs exists for linux 
too, and that's easy to obtain them.
thanks.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.n/a
2.
3.
	

Additional info:
Comment 1 Michael Lee Yohe 2002-12-09 10:56:30 EST
Priority == enhancement.

The philosophy behind this is "good" in intentions but poor with respect to what
you are describing.  For example - this translates to:

We don't give a piece of software for free because the people who own it want
money for it.  But, you can pick it up for free (even though the people who own
it, and the rights thereof, want money) at the following URL.  Or, we can
provide the conduit by which you can install this software that is not free FOR
free in our distribution.

This is not a good idea.  Mind you, Red Hat Linux is geared with professionalism
in mind - open-source is their target in the distribution sector.  It is nice,
to me, for instance to know that Red Hat stands out from the crowd on the stance
that "open source is the way to go".  Source code released under licenses which
accrue restrictions (i.e. monetary, availability, etc.) is what Red Hat has
seemingly tried to move away from.  Newbies alike can simply search on the web
for alternatives to adding "multimedia" support without the backing of a
corporate sponsor (ever perused comp.os.linux.misc?)

Adhering to the law and to the spirit of the law is a good pat on the back to
Red Hat, IMHO.
Comment 2 Bill Nottingham 2002-12-09 12:59:31 EST
No. Sending people to potentially untrusted third-party sites for software is a
Really Bad Idea(tm).

Note You need to log in before you can comment on or make changes to this bug.