Bug 7918 - linuxconf refuses to start, "segmentation error," dumps core
linuxconf refuses to start, "segmentation error," dumps core
Status: CLOSED DUPLICATE of bug 7874
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-20 18:40 EST by William Lutts
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-10 17:17:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Lutts 1999-12-20 18:40:32 EST
With 6.1 fully upgraded and the latest linuxconf posted on Dec. 15, 1999,
linuxconf worked fine for two days, then crashed in the middle of
configuring Samba. Henceforth it refused to start at all from the menu, or
from an X-terminal, or from a text terminal. Error message generated said
only "segmentation error (core dump)" Command "$file core" suggested that
it was a signal 11, memory problem. The rest of Redhat worked fine. So did
Win '98 when I rebooted. Physical memory problem unlikely. I tried many
things and RH tech support scratched their heads too. Then after taking a
break I realized that if linuxconf went terminally insane while configuring
Samba, it might make sense to look at the file /etc/smb.conf. Sure enough!
The Samba configuration file smb.conf was full of non-printing garbage
characters, in such a state as to justify the description "totally gorfed."

Solution: In the Samba section of /usr/doc there is an "examples"
directory. In that directory is a copy of the original Samba configuration
default file. Delete or rename the gorfed smb.conf in /etc and copy the
original Samba configuration file from the Samba "examples" directory into
/etc, taking care to rename it to smb.conf. Now linuxconf works fine once
more. Why it gorfed the smb.conf file in the first place I don't know. If
it will do it again, I don't know that either. Hope not.
Comment 1 jmorton 2000-01-10 09:05:59 EST
I encountered the exact problem after configuring Samba.
Comment 2 Nalin Dahyabhai 2000-01-10 17:17:59 EST
*** This bug has been marked as a duplicate of 7874 ***

Note You need to log in before you can comment on or make changes to this bug.