Bug 79258 - Error found in regression results
Error found in regression results
Status: CLOSED NOTABUG
Product: Red Hat Database
Classification: Red Hat
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
Patrick Macdonald
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-08 22:24 EST by jimomura
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 10:47:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jimomura 2002-12-08 22:24:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Win98; U)

Description of problem:
I have just downloaded Red Hat Database 2 and loaded it on Red Hat Linux 7.3 (1.2 GHz Duron
processor using the Athlon kernel, with system updates to 2002-10-10) and run the regression test.
The following was in the "regression.diff" file:

*** /usr/lib/pgsql/test/regress/expected/random.out	Thu Jan  6 06:40:54 2000
--- /usr/lib/pgsql/test/regress/results/random.out	Sun Dec  8 21:19:56 2002
***************
*** 31,35 ****
    WHERE random NOT BETWEEN 80 AND 120;
   random 
  --------
! (0 rows)
  
--- 31,36 ----
    WHERE random NOT BETWEEN 80 AND 120;
   random 
  --------
!     122
! (1 row)
  

======================================================================


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Patrick Macdonald 2002-12-09 09:45:50 EST
First, thanks for downloading RHDB 2.0. 

The community random test will fail sometimes.  Rerunning the regression
test will probably give a different result. It's in the PostgreSQL community
archives as well as the RHDB documentation at the bottom of this page:

http://www.redhat.com/docs/manuals/database/RHDB-7.1.3-Manual/install/regress.html

The RHDB 2.0 documentation does not contain information on how to rebuild from
source so the above link is not present in the RHDB 2.0 Getting Started / 
Installation Guide.  

I'm returning this bug with the above explanation.  Please respond or close
this bug at your earliest convenience.  If I don't we don't hear back from
you by end of week, I'll assume that it's ok to close this bug. 

Cheers,
Patrick
Comment 2 jimomura 2002-12-13 10:55:56 EST
     I have been reading the documentation for RHDB 2.0 for the last few days
in order to understand the situation better.  Unfortunately, there is a *lot*
I still have to read.  I have read the online page you pointed out.

     It is still not clear whether this is just "a known issue (ie. not
really a bug at all) in the test program," or whether something is actually
wrong.  I have not had a chance to use that computer to re-run the test yet.

     Due to the above, I have no opinion whether the bug should be "closed."
Perhaps you can leave it open in case someone else has the time to address
it?
Comment 3 Patrick Macdonald 2002-12-16 10:47:59 EST
This is a known issue with the PostgreSQL community regression test
bucket.  Once every X times, the random test will fail.  It's not
really a bug, but it is a poorly designed test.  The RHDB post-installer
regression test bucket combines the entire PostgreSQL community
test with several RHDB specific ones.   

The RHDB post-installer checks to see if you failed on that specific
test.  If it finds a failure, the failure is reported but there should
also be some output stating that this failure can be safely ignored.

I'm going to close this as NOTABUG and will note the Random test failure
on the FAQ at sources.redhat.com/rhdb.

Note You need to log in before you can comment on or make changes to this bug.