Bug 79263 - Standard window sizes are too large to display on screen at 800x600
Standard window sizes are too large to display on screen at 800x600
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdeadmin (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-09 00:33 EST by Dave
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-10 10:27:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave 2002-12-09 00:33:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
With the display set to 800x600 the standard window modules are too large for 
the screen.  An example is menu => configure panel => preferences.  This window 
is resizable horizontally but not vertically which pushes the buttons at the 
bottom down behind the task bar and the bottom edge of the window is off the 
screen.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set screen resolution to 800x600 (and restart if necessary)
2.Click menu => configure panel => preferences
3.Try to click the OK button on the resulting window
	

Actual Results:  The ok and cancel buttons are hidden behind the applications 
bar.  Moving the applications bar to one side, I still cannot get to the bottom 
edge of the window to resize it.

Expected Results:  I expected the window to resize to the available screen area 
and display scroll bars if needed.  

Additional info:

I managed to force my video card into 1024x768 by lying to it about how much 
memory it had (not a recommended practise).  I then tried to resize the same 
window - it is fixed to the size of the content of the 'look & feel' tab as a 
minimum size.
OK, it isn't a big deal, but it blows the whole idea of 'running linux on an 
old box' out of the water for good!
This is not the only window with this behaviour - I'll make a list if you feel 
that the problem is worth addressing.
Comment 1 Ngo Than 2002-12-09 05:20:35 EST
It does not more sense to run KDE in 800x600 or 640x480 resolution.
The default resolution is 1024x768.

It will look very bad, if the we do that.

In your case i recommend that you should resize such window at the first
start. If you start this application later again, it should have the correct
size, which you had before.

I close this bug as wontfix.
Comment 2 Dave 2002-12-09 18:36:06 EST
1. Many users have older computers that won't go to 1024x768, and that includes 
some of the machines I use here on a regular basis.
2. My preferred setting is 800x600 so I can read what is on the screen without 
having to resort to wearing glasses or getting headaches after a few hours.
3. It is bad programming practise to force your preferences on the end user - 
who said that KDE looks bad at 800x600?   According to web hits counted by  
counters.com (http://www.thecounter.com/stats/2002/November/res.php):
Fri Nov 1 00:05:01 2002 - Sat Nov 30 23:55:05 2002   30.0 Days
         800x600    150120300 (48%) 
        1024x768    121282316 (39%) 
        1280x1024    13722590 (4%) 
        1152x864      9663894 (3%) 
         640x480      8603330 (2%) 
        Unknown       3853206 (1%) 
        1600x1200     2355187 (0%) 
My point is that you shouldn't discount 48% (the clear majority) of the users - 
I can name a few presidents that wished they'd had a margin as wide as that!

Your comment about resizing is ridiculous - I did state that I had to force the 
card into believeing it had more memory than it has in order to get it up to 
1024x768 just to try the resizing operation - I would not dream of trying to 
run it at that setting for any period of time, and neither would anyone else 
with over 25 years of experience.

Give me a couple of months to get linux figured out and I'll help you add in 
the scrollbars if I have to!
Comment 3 Ngo Than 2002-12-10 11:10:07 EST
>1. Many users have older computers that won't go to 1024x768, and that includes 
> some of the machines I use here on a regular basis.

i don't recommend to run KDE on such old machine.

>2. My preferred setting is 800x600 so I can read what is on the screen without 
>having to resort to wearing glasses or getting headaches after a few hours.

Hmm, you could change for example the font size ...

> 3....

thanks for nice stats. But i don't think that this problem should be fixed.
Sorry, i close this bug.



Note You need to log in before you can comment on or make changes to this bug.