Bug 79273 - redhat-config-printer does not allow to enter SMB printer share manually.
redhat-config-printer does not allow to enter SMB printer share manually.
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-printer (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-09 08:44 EST by Pavel
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-09 14:24:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel 2002-12-09 08:44:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207

Description of problem:
redhat-config-printer 0.6.15-1 from rawhide does not allow to enter SMB printer
share manually. In my case it did not find correct printer share, so I was
unable to setup SMB printer.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to define SMB printer.
2.
3.
	

Actual Results:  Wizard asks you to choose one of the SMB printer shares it found

Expected Results:  Allow to enter share name manually in addition to detected
printer shares.

Additional info:
Comment 1 Tim Waugh 2002-12-09 08:48:06 EST
You can of course edit it afterwards and enter the details manually.

But I'm interested in why the share wasn't initially discovered.  What was the
share that you were after, and does it appear in the output of 'smbclient -N -L
<machinename>'?
Comment 2 Pavel 2002-12-09 09:08:19 EST
I don't have a problem with editing config files manually, but the sole purpose
of the GUI tool is to avoid this, so I believe it still should be corrected.

output of the command:
>smbclient -N -L prouter
added interface ip=10.12.0.31 bcast=10.12.0.255 nmask=255.255.255.0
Anonymous login successful
Domain=[NCDEV] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]

	Sharename      Type      Comment
	---------      ----      -------
Error returning browse list: NT_STATUS_ACCESS_DENIED

	Server               Comment
	---------            -------
	ACCOUNTING           
	AITANE               aitan
	ALEXB-2000           
	ALEXB-XP             
       .... (long list of machines in the domain)

	Workgroup            Master
	---------            -------
	NCDEV                PROUTER
	SIGTEK               ST260B
	WORKGROUP            MASTER_44


Comment 3 Tim Waugh 2002-12-09 09:57:39 EST
(I don't mean editing config files, but using the 'edit' option in the config tool.)

I can't tell from the output if the share you wanted is there or not, since I
don't know its name. ;-)

Which one are you after?
Comment 4 Pavel 2002-12-09 10:44:31 EST
Well, when I try to edit printer (I created an lpd printer, too), I get the
following traceback, and I was about to bugzilla it, too:
Couldn't load driver information.Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 467, in edit_button_clicked
    if self.editQueue.editQueueDialog (iter):
  File "/usr/share/printconf/util/editQueue.py", line 413, in editQueueDialog
    self.write_driver_options ()
  File "/usr/share/printconf/util/editQueue.py", line 906, in write_driver_options
    for option_tuple in option_list:
TypeError: iteration over non-sequence

So, right now it's not an option :).

As you can see, no shares are displayed by the command, error message "Error
returning browse list: NT_STATUS_ACCESS_DENIED " displayed instead. This server
does not allow anonymous users to browse its shares. 

When I run "smbclient -L prouter -U pavel", I get following output:
added interface ip=10.12.0.31 bcast=10.12.0.255 nmask=255.255.255.0
Password: <my password>
Domain=[NCDEV] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]

	Sharename      Type      Comment
	---------      ----      -------
	ptk            Printer   Tektronix Phaser 850N
	IPC$           IPC       Remote IPC
	print$         Disk      Printer Drivers
	tftpboot       Disk      
	c              Disk      
	KyoceraPub     Printer   KyoceraPub
	ftproot        Disk      
	Aitan          Disk      
	ADMIN$         Disk      Remote Admin
	Kyocera        Printer   KyoceraDevL
	C$             Disk      Default share

	Server               Comment
	---------            -------
	ACCOUNTING           
	AITANE               aitan
	ALEXB-2000           
	ALEXB-XP             
	.... (long list of machines) 

	Workgroup            Master
	---------            -------
	NCDEV                PROUTER
	SIGTEK               ST260B
	WORKGROUP            MASTER_44

So, generally, I'm after ptk and Kyocera printers.
Comment 5 Tim Waugh 2002-12-09 11:24:55 EST
Okay.

Well, as for the traceback, it's a foomatic problem (actually caused by Omni),
which is fixed in foomatic-2.0.2-5, which will shortly appear in rawhide.

How about if I add a button for specifying a non-browseable share?
Comment 6 Pavel 2002-12-09 11:28:56 EST
sounds great for me :)

I think you may need to ask for username/password in addition to share name.
Comment 7 Tim Waugh 2002-12-09 14:22:45 EST
Should be fixed in redhat-config-printer-0.6.18-1, which will shortly appear in
rawhide.
Comment 8 Tim Waugh 2002-12-09 14:24:23 EST
Well, the GUI bits are there anyway.  Doesn't quite work yet.
Comment 9 Tim Waugh 2002-12-10 04:46:42 EST
Okay 0.6.19-1 has it fixed.

Note You need to log in before you can comment on or make changes to this bug.