Bug 79279 - Blank package name search returns junk on Advanced Search page
Blank package name search returns junk on Advanced Search page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Devel
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Greg DeKoenigsberg
Fanny Augustin
:
Depends On:
Blocks: 76241
  Show dependency treegraph
 
Reported: 2002-12-09 09:39 EST by Matt Jamison
Modified: 2007-04-18 12:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-10 12:35:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Komenda 2002-12-09 09:39:36 EST
Description of Problem: Should probably limit the package name search to 3
characters as well.
Comment 1 Josef Komenda 2002-12-09 09:45:13 EST
Also, this may need to be optimized:

Additional comment by cturner@redhat.com on 2002-12-07 14:26:47

package search "works" but it doesn't behave like system search.  it still uses
the old query_into_set instead of the newer datasource-driven mechanism.  rob
and I have cleaned up the system search to be a bit more datasource-friendly. 
the errata and package search need to be done similarly, else we end up with the
same search mishmash we had before.  this should be an easy conversion; rob or I
can help if there are any questions with how we did things.  once that has been
done, I will optimize the queries to improve performance.  one of the problems
with the current search is that it should only store the latest versions of
packages in the set, not store all matches and expect the elaborator to filter
it as it seems to do now.
Comment 2 Chip Turner 2002-12-10 12:35:06 EST
fixed.

now if you do a search w/o typing text in, it just takes you to the search page
of the appropriate type.
Comment 3 Josef Komenda 2002-12-10 18:13:39 EST
Looks good on dev, closing.

Note You need to log in before you can comment on or make changes to this bug.