Bug 79309 - rpm seems to have a problem with passing ftp URL on commandline to install packages with
Summary: rpm seems to have a problem with passing ftp URL on commandline to install pa...
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-09 22:26 UTC by Mike A. Harris
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-10 11:46:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2002-12-09 22:26:50 UTC
[root@devel root]# rpm -q rpm
rpm-4.1-1.06

[root@devel root]# cat /etc/redhat-release
Red Hat Linux release 8.0 (Psyche)

[root@devel root]# rpm -Uvh
ftp://mharris@porkchop.devel.redhat.com/mnt/redhat/beehive/comps/dist/8.0.1-scratch/XFree86/4.2.99.2-0.20021208.0/i386/XFree86-*4.2.99.2-0.20021208.0.i386.rpm
Password for mharris@porkchop.devel.redhat.com:
[root@devel root]#

Password is definitely correct here.  Either rpm is broken with ftp URLs in
this regard, or if I'm doing something it does not support officially, it
should display an error message at least to tell me I'm a doofus.

Please beat me with a cluestick now..  ;o)

Comment 1 Jeff Johnson 2002-12-09 22:42:28 UTC
WORKSFORME:

bash$ rpm -qp ftp://jbj@porkchop/home/devel/jbj/tmp/rpm-4.2-0.20.src.rpm
Password for jbj@porkchop: 
rpm-4.2-0.20


Comment 2 Mike A. Harris 2002-12-09 23:57:48 UTC
That isn't the command I ran though.  I ran a globbed RPM install over
ftp.  You ran a non-globbed ftp package query.  Different codepaths.

Either it's a bug in RPM - not doing what it is supposed to and installing
the packages, or it is me not using the correct syntax and RPM not presenting
me with an error message to tell me that my input is bad/bogus.

Either way I consider it a bug.  Please don't say WORKSFORME, if what you
really mean is DONTCARE.  I'd rather you tell me you don't care, and
close it WONTFIX.  At least I know explicitly then the reason for closure.


Comment 3 Jeff Johnson 2002-12-10 00:05:46 UTC
WORKSFORME (again):

bash$ sudo rpm -Uvh ftp://jbj@porkchop/home/devel/jbj/tmp/rpm-4.2-0.20.*.rpm
Password for jbj@porkchop: 
Retrieving ftp://jbj@porkchop/home/devel/jbj/tmp/rpm-4.2-0.20.src.rpm
   1:rpm                    ########################################### [100%]
bash$

Comment 4 Mike A. Harris 2002-12-10 00:18:25 UTC
Ok, I'm lying.  I made it all up just to see if I could trick you.

Thanks for at least trying to troubleshoot what could be different
between your system and mine if it WORKSFORYOU, because it does not
work for me, and I've now tried on 3 different systems.  All running
stock Red Hat Linux 8.0 plus updates with no unofficial RPM packages
installed.



Comment 5 Mike A. Harris 2002-12-10 00:19:08 UTC
Fixing bug resolution to WONTFIX/DONTCARE.

Comment 6 Jeff Johnson 2002-12-10 11:48:54 UTC
WORKSFORME (Yet Again):
bash$ sudo rpm -Uvh
ftp://jbj@porkchop/mnt/redhat/beehive/comps/dist/8.0.1-timp/rpm/4.2-0.20/i386/*.rpm
Password for jbj@porkchop: 
Retrieving
ftp://jbj@porkchop/mnt/redhat/beehive/comps/dist/8.0.1-timp/rpm/4.2-0.20/i386/popt-1.8-0.20.i386.rpm
Retrieving
ftp://jbj@porkchop/mnt/redhat/beehive/comps/dist/8.0.1-timp/rpm/4.2-0.20/i386/rpm-4.2-0.20.i386.rpm
Retrieving
ftp://jbj@porkchop/mnt/redhat/beehive/comps/dist/8.0.1-timp/rpm/4.2-0.20/i386/rpm-build-4.2-0.20.i386.rpm
Retrieving
ftp://jbj@porkchop/mnt/redhat/beehive/comps/dist/8.0.1-timp/rpm/4.2-0.20/i386/rpm-devel-4.2-0.20.i386.rpm
Retrieving
ftp://jbj@porkchop/mnt/redhat/beehive/comps/dist/8.0.1-timp/rpm/4.2-0.20/i386/rpm-python-4.2-0.20.i386.rpm
Preparing...                ########################################### [100%]
   1:popt                   ########################################### [ 20%]
   2:rpm                    ########################################### [ 40%]
   3:rpm-build              ########################################### [ 60%]
   4:rpm-devel              ########################################### [ 80%]
   5:rpm-python             ########################################### [100%]

Whatever. I can't fix what I can't reproduce, and you seem more
interested in ranting than trying to supply additional and useful
information. 



Note You need to log in before you can comment on or make changes to this bug.