Bug 79359 - fonts rendered at wrong size under KDE
fonts rendered at wrong size under KDE
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-10 13:28 EST by Rick Gaudette
Modified: 2007-04-18 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:33:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Gaudette 2002-12-10 13:28:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Using KDE as my desktop fonts are sized incorrectly this occurs in GTK apps as
well.  Once I run gnome-font-properties the font sizes are corrected.  But, this
also replaces the kde desktop with the gnome desktop.

I have edited /etc/X11/Xresources to match the dpi (88) for my X setup but that
did not help.  It is also set at 88 in gnome-font-properties 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.use KDE as a desktop
2. observe fonts in apps as too small
3. run gnome-font-porperties
4. observed font size changes
	

Actual Results:  KDE desktop is replaced with gnome desktop upon running
gnome-font-porperties


Expected Results:  When running KDE Xft fonts should size correctly


Additional info:
Comment 1 Rick Gaudette 2002-12-10 13:35:01 EST
The change in font size appears to happen only to GTK (i.e. gedit, eclipse) apps
and not KDE apps (i.e. kate).  Do the GTK apps assume a DPI until
gnome-font-properties is run?
Comment 2 Owen Taylor 2003-01-09 15:11:17 EST
I don't understand what you mean by "KDE desktop is replaced with 
gnome desktop upon running gnome-font-properties". gnome-font-properties
will sart gnome-settings-daemon, which will propagate various GNOME
settings to GNOME apps running currently. But it shouldn't start
nautilus, or gnome-panel, or metacity. (The standard KDE konqueror,
kicker, kwin should run unaffected.)

Until you run gnome-font-properties, GNOME apps will get the defualt
font size. They really should get the size configured within KDE
(bug 76887) but that is a quite large project.

I'm going to resolve this as a duplicate of bug 76887. If either:

 a) Running gnome-font-properties does anything other than change
    settings for gnome apps.

 b) The size you get for GNOME apps on starting KDE is something
    other than the default font size (the default size should be
    the same for GNOME and KDE until you configure one or the other.)

Could you reopen this bug and add more details? Thanks.

*** This bug has been marked as a duplicate of 76887 ***
Comment 3 Rick Gaudette 2003-01-09 15:24:50 EST
When I run gnome-font-properties all of my icons disappear and the desktop
(background) area is replaced by whatever I had configured under gnome.  In
fact,  after running gnome-font-properties I can know change the background
using gnome-control-center.  Thus it seems that gnome has "stolen" control of
the the background. I don't know if that is so much a bug as just weird behavior.

I guest it would all be moot if I could find out how to change the "default font
size" for gnome apps without having to run gnome-font-properties.

Comment 4 Owen Taylor 2003-01-14 15:18:21 EST
What I think is happening:

 - Konqueror sets ESETROOT_PMAP_ID to point to it's root window pixmap.
   The way ESETROOT_PMAP_ID is supposed to work is that it points to a 
   pixmap on a separate display connection that is "persistant", and
   the next person setting the background calls XKillClient() for
   that connection. But for Konqueror, the pixmap is owned by the
   main Konqueror process.

 - gnome-font-properties starts gnome-background-properties, which tries
   to set the background. It does an XKillClient() on the root background
   pixmap which kills Konqueror.

I'm not sure if it's we should

 - Fix konqueror
 - Fix gnome-settings-daemon to say "hmm, I seem to be running under KDE,
   let's not set the background". (I think we have kde-is-running code
   somewhere else)
 - Both
Comment 5 Jonathan Blandford 2003-01-14 15:40:44 EST
I vote both.  I don't think the gnome-settings-daemon should run at all if KDE
is going.
Comment 6 Thomas Hartwig 2005-12-15 06:58:17 EST
This problem still exists in Fedora Core 4. However there are now no settings
changed when running gnome-settings-daemon or gnome-font-properties expect the
ugly fonts for gnome apps are cleaned up.
I did an upgrade from RedHat and/or Fedora, did not test a fresh Fedora install.
Comment 7 Petr Rockai 2006-07-17 14:40:06 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 8 Bill Nottingham 2006-10-18 14:33:19 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.