Bug 79367 - ftp client: runique on stops mget from working
ftp client: runique on stops mget from working
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: ftp (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Raszyk
Depends On:
  Show dependency treegraph
Reported: 2002-12-10 15:32 EST by Donnie Cambre
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.17-23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-22 08:08:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Donnie Cambre 2002-12-10 15:32:34 EST
Description of Problem:

The ftp client does not support the combination of 'runique' and 
'mget' as stated in the man pages.  If runique is turned on during an ftp session, 'mget' fails to get 
anything.  However, 'get' will get the file and rename it with a ".1" (or appropriate 

Version-Release number of selected component (if applicable):
Not sure, 
whatever comes with RedHat 7.1 and 7.3 by default

How Reproducible:

to Reproduce:
1. FTP to a site with some files to get
2. Turn on runique (ftp> runique)
Attempt to do an mget (ftp> mget *)
4. No files will be transferred.
5. Turn runique off (ftp> 
6. Attempt to do an mget (ftp> mget *)
7. All matching files will be transferred
Turn runique off again
8. Try 'get' and it will get the specified file (ftp> get filename)
Try 'get' again and it will get the file and rename it with a .1 (ftp> get filename)

Mget does not transfer files with runique on but works fine with runique 

Expected Results:
mget should get all the matching filenames and rename them with a 
suffix if .## (such as .1) when runique is turned on.

Additional Information:
I tried this 
in SuSE Linux 7.3 and it has the same problem.
Comment 1 Thomas Woerner 2004-04-21 11:31:00 EDT
Is this /usr/bin/ftp or /usr/kerberos/bin/ftp?
Comment 2 Donnie Cambre 2004-04-21 11:33:45 EDT
This is /usr/bin/ftp
Comment 3 Thomas Woerner 2004-10-07 10:04:34 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.
Comment 4 Donnie Cambre 2004-10-14 13:36:04 EDT
Tested with the same result in RedHat Enterprise Linux Advanced Server
2.1.  If runique is enabled, mget does not function.
Comment 5 Thomas Woerner 2004-12-07 06:38:03 EST
Please have a look at 


This package should fix the problem.

Please remeber that this is a test package, which might be pushed out as an
update package later if the fixes are ok.
Comment 6 Donnie Cambre 2004-12-07 10:05:41 EST
Tested the linked update (ftp-0.17-12.1.3.i386.rpm) on RHEL AS 2.1 and it fixes
the problem.
Comment 7 Petr Raszyk 2005-08-22 08:02:26 EDT
This bug was fixed by Thomas Woerner <twoerner@redhat.com> on 2004-12-07
It is a patch netkit-ftp-0.17-runique_mget.patch.
This 'bug' does not occure in FEDOR CORE 4.

Note You need to log in before you can comment on or make changes to this bug.