Bug 79394 - RFE: adding arabic fonts
RFE: adding arabic fonts
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
8.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
http://www.linux.org.sa/download/Kacs...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-11 03:52 EST by Mohamed Eldesoky
Modified: 2013-01-10 16:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-04 16:58:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohamed Eldesoky 2002-12-11 03:52:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
These are GPLd arabic fonts, that would be very helpful for arabic users, and
could enable RedHat to do more applications arabic capable.
http://www.linux.org.sa/download/KacstArabicFonts.tar.gz


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.unpack the package above
2.copy it to .fonts directory
3.start using arabic
	

Additional info:
Comment 1 Mike A. Harris 2002-12-17 17:18:57 EST
Reassigning enhancement request to distribution component
Comment 2 Bill Nottingham 2002-12-30 00:53:46 EST
Owen, opinions on the fonts?
Comment 3 Mike A. Harris 2002-12-30 00:58:16 EST
As long as they are truely free, and not of questionable origin, and they
look half decent, I don't see any reason why we shouldn't ship them.
Comment 4 Owen Taylor 2002-12-30 11:05:33 EST
These fonts aren't OpenType fonts so they are useless for us. (Well, worse
than useless, because currently we don't gracefully handle Arabic TTF
fonts that don't have the necessary tables - you get programs aborting
with:

** ERROR **: file shape.c: line 74 (pango_shape): assertion failed:
(glyphs->num_glyphs > 0)

Though that's a bug that can be fixed)

There are one or two free OpenType arabic fonts, - I was thinking of 
assembling ttfonts-me and ttfonts-indic packages to extend the range
of the languages we cover.
Comment 5 Mohamed Eldesoky 2003-01-03 13:18:46 EST
We can work together to fix all the problems.
I have emailed the authors of the fonts already
Comment 6 Owen Taylor 2003-01-10 17:41:30 EST
Turns out that the fonts do have some of the OpenType tables ... Pango
is having problems because they conform to an earlier Microsoft 
format rather than full OpenType (no GDEF table). I probbably can
make Pango work around that.
Comment 7 Owen Taylor 2003-01-10 19:26:23 EST
Have a fix for this in Pango CVS now.
Comment 8 Mohamed Eldesoky 2003-01-11 10:25:40 EST
Thanks alot Owen for the time.
Please feel free to reach me for any kind of help.
I am willing to give the necessary time to help.
Also, what should it take in order to make the installation of Linux in Arabic
possible ??
Comment 9 Christian Rose 2003-01-11 11:02:15 EST
Probably only someone interested in making it happen. :)
If you are interested, follow the instructions on http://i18n.redhat.com/.
Comment 10 Mohamed Alkanhal 2003-01-22 01:01:17 EST
KacstArabicFonts is just updated. There are now nine GPLd fonts. They look 
better than before. Should you have any comment, please let me know. Thanks.

http://www.linux.org.sa/download/KacstArabicFonts.tar.gz


Comment 11 Owen Taylor 2003-01-22 11:43:51 EST
My comment: 

 Please, please, get the upstream people to assign a version number to
 the the tarball. Files that change content while keeping the same name
 are extremely difficult to deal with when packaging.

Comment 12 Mohamed Alkanhal 2003-01-22 12:36:41 EST
Thanks Owen for your comment. The person in charge just assigned a version 
number to it. You can try it now.
Comment 13 Mohamed Eldesoky 2003-01-23 02:17:58 EST
Owen  Mohamed Alkanhal meant you can download the newest version from this link http://www.linux.org.sa/download/KacstArabicFonts-1.1.tar.gz  Regards M.Eldesoky 
Comment 14 Mohamed Alkanhal 2003-01-23 05:08:30 EST
ooops, I forgot to include the link of the latest version in my previous post. 
Thanks Mohamed Eldesoki for your help.

Again, the latests tarball is at
http://www.linux.org.sa/download/KacstArabicFonts-1.1.tar.gz  
Comment 15 Mohamed Eldesoky 2003-01-30 01:02:24 EST
Can we make these fonts find its way to XFree86 ??
To be available all the time with all distros ??
Searched in their site, but didn't find any contacts that I can do !!
Comment 16 Owen Taylor 2003-02-04 16:58:41 EST
Upgraded version in the tree to the new tarball.

Note You need to log in before you can comment on or make changes to this bug.