Bug 7940 - cut-and-paste broken
cut-and-paste broken
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 1999-12-21 17:48 EST by Joe Harrington
Modified: 2014-03-16 22:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-01-19 12:26:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joe Harrington 1999-12-21 17:48:16 EST
This has been a problem with Netscape on Linux since the beginning:

1. If you cut in Netscape and paste into emacs or xterm, you may or
may not get your selection.  It seems random, and a selection that
doesn't work at one time might work later.

2. There's always blank space before every line but the first, even if
there's no margin on the page (and who ever heard of pasting leading

This is still in

Comment 1 Alexandre Blanchette 2000-01-13 22:58:59 EST
Netscape manage its own selection/copy/cut/paste buffer, so it you use
netscape's cut (alt-x) it will stay only inside netscape.

When pasting data around various apps, i suggest you to use button 1 (left
button) to select, and then use button 2 (middle button) to paste. NOTA: It will
paste the piece of text you selected, in some occasion, this is a bit akward to
use. Also, i haven't figured out how to cut text, not simply copy it. (sp?)
Comment 2 Joe Harrington 2000-01-14 15:06:59 EST
When I said cut I meant copy, of course.  You can't cut from a web page since
Navigator isn't an editor.  I have only ever used mouse-1 to copy and mouse-2 to
paste.  The bug I am reporting happens when I do this.  Try it.
Comment 3 Bill Nottingham 2000-01-18 14:50:59 EST
Hm... I can't reproduce this here; copy & paste works like
I expect; selecting things on this page and pasting them
into vi (running in a gnome-term) works OK.
Comment 4 Joe Harrington 2000-01-18 16:01:59 EST
I tried it going into a gnome terminal running vi and I still get
blank space at the start of every line but the first.  Do you see this
behavior?  If not, let's try to find the differences in our
configurations, starting with rpms and X resources.  The amount of
blank space differs per web page.  Here's what I get for an item on
Red Hat's current homepage:

Linux Demo Day to Seize on
  Win2K Publicity
  Linux user groups organize to educate
  the public about Windows alternatives.
  Plus: news roundup.
  Be To Offer BeOS 5.0 For
  Well, sort of. The Register reports that
  only a portion of the OS will be
  released for non-commercial use.

I cut exactly those words (i.e., nothing more) with both left and
middle buttons.  There was no indent on the web page, but I get an
indent when I paste.

The outright failure to paste is intermittent, as I said.  It seems to
have something to do with having cut something in some other
application first, but even then it's intermittent.  It used to be I
could fix the problem by cutting a null selection in that application,
but now (last few releases of XFree86) it seems impossible to clear
the cut buffer; if I try, I get whatever was in it before.

There are some web pages from which I can *never* cut (the selection
doesn't highlight).  I can also not save those pages as text.  That's
different from this problem but may be related.  Try cutting and
pasting (or saving as text) the main text from
Comment 5 Bill Nottingham 2000-01-19 12:26:59 EST
Reported to netscape; they may fix it in a later version.
These shold be fixed by 5.0, however.

Note You need to log in before you can comment on or make changes to this bug.