Bug 79400 - redhat-config-date fails to launch
redhat-config-date fails to launch
Status: CLOSED DUPLICATE of bug 76313
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-11 04:43 EST by Nick Dimiduk
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-11 04:46:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Dimiduk 2002-12-11 04:43:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
trying to use the GUI date config tool reports the following error to the terminal:
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'

Please let me know if i need to post any more information... this is my first
bug report.  In the time being, could anyone tell me where to set the proper
timezone for my system so that when the system boots it does not set the time to
14 hours ahead?
Thanks,
-nd

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open a terminal window
2. type "/usr/bin/redhat-config-date"
3. enter root password when prompted

Actual Results:  the output pasted above was given

Expected Results:  the date/time GUI should have poped up

Additional info:

This problem did not happen before i upgraded my motherboard to an asus a7v8x. 
Nor did i have the problem with the hardware browser which is mentioned in bug
number 78100.
Comment 1 Nick Dimiduk 2002-12-11 04:46:48 EST
Oops... to update my last comment: the system time is set at boot after
connecting to a time server.  The resulting system time is set 14 hours ahead of
local time... GMT +9 I believe.  Sorry for the confusion.
-nd
Comment 2 Brent Fox 2002-12-11 09:51:12 EST
The contents of the /etc/sysconfig/clock file must have changed.  I don't think
that the motherboard change affected this.  This bug report is a duplicate of
bug 76313, so I'm going to close it as a dupe.  However, you can still respond
to this bug report and I'll try to help you out.

Can you post the contents of your /etc/sysconfig/clock file?  I think what has
happened is that a timezone that redhat-config-date doesn't understand has been
set in the /etc/sysconfig/clock file.  

*** This bug has been marked as a duplicate of 76313 ***

Note You need to log in before you can comment on or make changes to this bug.