Bug 79404 - Estonian keyboard layout broken
Estonian keyboard layout broken
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 80464 (view as bug list)
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-11 05:55 EST by Jaanus Kivistik
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 02:39:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaanus Kivistik 2002-12-11 05:55:10 EST
Description of Problem:
Estonian keyboard layout is broken (keys "greater than", "less than", "pipe",
"carot" don't work).


Version-Release number of selected component (if applicable):
XFree86-4.2.99.2-0.20021209.0

How Reproducible:
Selected Estonian layout("ee") try to enter symbols "greater than", "less than",
"pipe", "carot".


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
nothing or " "

Expected Results:
proper symbols

Additional Information:
Comment 1 Jaanus Kivistik 2002-12-13 08:09:49 EST
"<" seems to be AltGr + "," and ">" is AltGr + "." (which are wrong mappings on
a Estonian keyboard). Mapping of "pipe" is yet to be determined...
Comment 2 Mike A. Harris 2002-12-26 23:05:40 EST
*** Bug 80464 has been marked as a duplicate of this bug. ***
Comment 3 Jaanus Kivistik 2002-12-27 03:00:14 EST
Adding "XkbModel" "pc105" to XF86Config-4 fixed all symbols, exept "pipe". Adding 

key <LSGT>  { type[Group1]="FOUR_LEVEL",
                  [      less,    greater,          bar,     brokenbar] };

to pc/ee symbols file fixed  "pipe" also, but I think there must be a cleaner
solution (maybe from a toplevel symbols file?)
Comment 4 Daniel Resare 2002-12-28 09:45:31 EST
this is also a problem for the swedish (se) keyboard. The suggseted solution
above works for me.
Comment 5 Daniel Resare 2003-01-20 18:05:50 EST
At least for the swedish keybaord, this is fixed in XFree86-4.2.99.3-20030115.0
Comment 6 Mike A. Harris 2003-01-20 21:10:51 EST
Is this working for estonian in the XFree86-4.2.99.3-20030115.0 release
or later now?  If not, then please let me know ASAP.
Comment 7 Jaanus Kivistik 2003-01-21 02:39:56 EST
Seems to be fixed in XFree86-4.2.99.3-20030115.0.

Note You need to log in before you can comment on or make changes to this bug.