Bug 794561 - Lenovo Workstaiton S30 -it shows wrong FW of HDD in the disk utility.
Summary: Lenovo Workstaiton S30 -it shows wrong FW of HDD in the disk utility.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev
Version: 6.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-17 05:34 UTC by wayneh
Modified: 2015-07-22 07:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The ata_id helper of udev did not swap all bytes of the firmware revision information. As a consequence, the firmware revision information of ATA disks stored in the udev database had its last two digits swapped. The ata_id helper has been modified to also swap the last two characters of the firmware revision, and the firmware revision information of ATA disks is now correct.
Clone Of:
Environment:
Last Closed: 2015-07-22 07:19:26 UTC


Attachments (Terms of Use)
dump file with WD HDD (1.94 KB, text/plain)
2012-02-20 08:43 UTC, wayneh
no flags Details
/lib/udev/ata_id --export /dev/sda (1.15 KB, text/plain)
2012-07-02 05:29 UTC, wayneh
no flags Details
/lib/udev/scsi_id --export --whitelisted -d /dev/sda (385 bytes, text/plain)
2012-07-02 05:29 UTC, wayneh
no flags Details
udevadm info --attribute-walk --name=/dev/sda (3.43 KB, text/plain)
2012-07-02 05:30 UTC, wayneh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1382 normal SHIPPED_LIVE udev bug fix update 2015-07-20 17:58:19 UTC

Description wayneh 2012-02-17 05:34:11 UTC
Description of problem:
check the HDD FW in the disk utility, it is not correct.


Steps to Reproduce:
1. Install RHEL6.2 on WD 2.5" 150GB STAT HDD.
2. Reboot system.
3. Boot to OS then check the HDD FW.
   Applications -> System Tools -> Disk Utility 
   You can observe the FW is "YA10".
   It should be "YA01".
    
Benchmark:
    1. This symptom is also observed with WD2.5" 300GB and 600GB SATA HDD.
    2. This symptom does not observe in Windows 7.
  
Actual results:
When using Samsung SAMSUNG 256GB SSD HDD.
it shows the FW of HDD is "CXM72L21" in the disk utility, the correct FW version is "CXM72L12".

When using WD 2.5" 150G SATA HDD.
it shows the FW of HDD is "YA10" in the disk utility, the correct FW version is "YA01".

Expected results:
When using Samsung SAMSUNG 256GB SSD HDD.
it shows the correct FW of HDD "CXM72L12" in the disk utility.

When using WD 2.5" 150G SATA HDD.
it shows the correct FW of HDD is "YA01" in the disk utility.

Additional info:
Intel Romley+Patsburg,

Comment 1 David Zeuthen 2012-02-17 11:49:20 UTC
We get this info from udev's ata_id tool, so reassigning. Please attach the output of

 udevadm info -q all -n /dev/sda

running as root (please /dev/sda with the device file of the disk in question).

Comment 3 wayneh 2012-02-20 08:43:03 UTC
Created attachment 564336 [details]
dump file with WD HDD

Comment 4 wayneh 2012-02-20 08:43:44 UTC
Hi Sir,
Please find the attached dump file when using WD HDD. Thanks.

Comment 5 rpecorella 2012-03-01 19:48:08 UTC
Hi David, do you have any additional on this issue. I need to give my management team and update on this one.

Comment 6 RHEL Product and Program Management 2012-05-03 05:13:43 UTC
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 7 Kay Sievers 2012-06-29 18:16:35 UTC
Can you please paste the output of:
  /lib/udev/ata_id --export /dev/sda

And:
  /lib/udev/scsi_id --export --whitelisted -d /dev/sda

And:
  udevadm info --attribute-walk --name=/dev/sda


We need to check where the wrong information is coming from.

Comment 8 wayneh 2012-07-02 05:29:20 UTC
Created attachment 595622 [details]
/lib/udev/ata_id --export /dev/sda

Comment 9 wayneh 2012-07-02 05:29:45 UTC
Created attachment 595624 [details]
/lib/udev/scsi_id --export --whitelisted -d /dev/sda

Comment 10 wayneh 2012-07-02 05:30:19 UTC
Created attachment 595625 [details]
udevadm info --attribute-walk --name=/dev/sda

Comment 11 wayneh 2012-07-02 05:32:20 UTC
Hi Sir,
I uploaded the info in the attachment. Thanks.

Comment 12 Kay Sievers 2012-07-05 14:58:29 UTC
Fixed upstream:
  http://cgit.freedesktop.org/systemd/systemd/commit/?id=daa9cf546ce7265645ced9592dd54c6b2fc04302

Thanks for tracking down this issue, seems nobody noticed so far.

Comment 14 Leos Pol 2015-04-15 09:26:57 UTC
I've no such hw to verify, but patch is present and looks sane.

Comment 16 errata-xmlrpc 2015-07-22 07:19:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1382.html


Note You need to log in before you can comment on or make changes to this bug.