Bug 79463 - "happy gnome" gdm theme is broken
"happy gnome" gdm theme is broken
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: librsvg2 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Mike McLean
: Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-11 17:16 EST by Nicolas Mailhot
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 05:37:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2002-12-11 17:16:46 EST
after a rawhide sync (including gdm-2.4.0.7-14) I had the surprise of finding a
broken login screen (almost only white).

turns out the blue curvy blue background is not stretched anymore but is
confined to a small stamp-like area in the upper-left screen corner ; harmless
but very strange effect:)
Comment 1 Nicolas Mailhot 2002-12-13 16:43:11 EST
Note that you still get a blue patch in about 1/9th of the screen (in 1280*1024)

The problem is purely confined to the stretching of the login screen blue part ;
but since the other elements (login frame and icon bottom-bar) which are
rendered correctly are whitish and the uncovered part is white, you get a
mostly-white effect.
Comment 2 Nicolas Mailhot 2002-12-13 16:44:24 EST
This using the original gdm « happy gnome » theme
Comment 3 Havoc Pennington 2002-12-19 19:04:55 EST
Does this happen with the default theme? It seems to be working in our 
test installs.
Comment 4 Nicolas Mailhot 2003-01-14 04:34:47 EST
The bluecurve theme is fine (sorry for the delay, seems I missed the bugzilla
mail notification). I just don't like it
Comment 5 Owen Taylor 2003-01-16 16:19:17 EST
Taking gdm target/blockers.
Comment 6 Owen Taylor 2003-01-16 19:29:52 EST
HappyGnome seems to be fine with 2.4.1.0-1
Comment 7 Nicolas Mailhot 2003-01-17 04:23:08 EST
I'm afraid I still have it with this gdm version.
An rpm -V shows only the gdm.conf changed.

And since I broke simultaneously on two different computers after a gdm update
i'd be surprized if it where some misconfiguration on my part.

What do you need to debug this ?
Comment 8 Owen Taylor 2003-01-17 09:44:46 EST
What are the changes in your gdm.conf? Anythign other than the theme
name?

Are you sure these machines actually have all the latest packages?
Are there any local packages installed? Does it matter what the system
local is?

Basically, in order to for me to any have a chance of debugging this,
we need to figure out how to make a fresh install reproduce the problem.

Comment 9 Nicolas Mailhot 2003-01-17 10:05:14 EST
> What are the changes in your gdm.conf? Anythign other than the theme
name?

--- /etc/X11/gdm/gdm.conf       2003-01-10 04:40:33.000000000 +0100
+++ gdm.conf    2003-01-17 10:10:57.000000000 +0100
@@ -101,9 +101,9 @@
 # If any distributions ship with this one off, they should be shot
 # this is only local, so it's only for say kiosk use, when you
 # want to minimize possibility of breakin
-AllowRoot=true
+AllowRoot=false
 # If you want to be paranoid, turn this one off
-AllowRemoteRoot=true
+AllowRemoteRoot=false
 # This will allow remote timed login
 AllowRemoteAutoLogin=false
 # 0 is the most anal, 1 allows group write permissions, 2 allows all write
permissions
@@ -164,7 +164,7 @@
 # Greeter has a nice title bar that the user can move
 TitleBar=false
 # Configuration is available from the system menu of the greeter
-ConfigAvailable=false
+ConfigAvailable=true
 # Face browser is enabled.  This only works currently for the
 # standard greeter as it is not yet enabled in the graphical greeter.
 Browser=false
@@ -195,7 +195,7 @@
 # and wish to have this translated you can have entries such as
 # Welcome[cs]=Vitejte na %n
 # Just make sure the string is in utf-8
-Welcome=Welcome to %n
+Welcome=Bienvenue sur %n
 # Don't allow user to move the standard greeter window.  Only makes sense
 # if TitleBar is on
 LockPosition=true
@@ -233,12 +233,12 @@
 ShowGnomeFailsafeSession=false
 ShowXtermFailsafeSession=false
 # Always use 24 hour clock no matter what the locale.
-Use24Clock=false
+Use24Clock=true
 # Use circles in the password field.  Looks kind of cool actually
 UseCirclesInEntry=false
 # These two keys are for the new greeter.  Circles is the standard
 # shipped theme
-GraphicalTheme=Bluecurve
+GraphicalTheme=happygnome
 GraphicalThemeDir=/usr/share/gdm/themes/
  
 # The chooser is what's displayed when a user wants an indirect XDMCP


> Are you sure these machines actually have all the latest packages?

Both systems are in-sync with Rawhide using apt (I can provide a rpm list if you
want). One started its life with RH 8.0, not so sure about the other

> Does it matter what the system local is?

One uses LANG="fr_FR", the other LANG="fr_FR.UTF-8"

> Are there any local packages installed?

Afraid yes. I use these computers.




Comment 10 Owen Taylor 2003-01-17 11:53:42 EST
Turns out to be the locale that is significant. I think that the
problem is that the he library we use  to do loading, librsvg, was 
using routines that expected the locale's numeric separator (,) instead 
of the default one (.).

This has been fixed in CVS since that last release.

2003-01-13  Dom Lachowicz <cinamod@hotmail.com>

        * *: Rework previous commit to use g_ascii_dtostr and g_ascii_strtod

2003-01-13  Dom Lachowicz <cinamod@hotmail.com>

        * rsvg-private.h: Add setlocale wrapper fns. Problem found by George
        Lebl (jirka@5z.com), work based on/inspired by a patch by him.
        * rsvg.c: Use above fns
        * rsvg-css.c: Ditto
        * rsvg-text.c: Ditto
        * rsvg-shapes.c: Ditto

=== librsvg 2.1.5 ===
Comment 11 Alexander Larsson 2003-01-21 05:37:17 EST
This is fixed in librsvg 2.2.0-1
Comment 12 Nicolas Mailhot 2003-01-21 13:34:57 EST
Fixed indeed. Thanks

Note You need to log in before you can comment on or make changes to this bug.